Date: Wednesday, March 14, 2018 @ 00:43:47
  Author: anthraxx
Revision: 307512

archrelease: copy trunk to community-any

Added:
  python-eventlet/repos/community-any/PKGBUILD
    (from rev 307511, python-eventlet/trunk/PKGBUILD)
Deleted:
  python-eventlet/repos/community-any/PKGBUILD

----------+
 PKGBUILD |  161 +++++++++++++++++++++++++++++--------------------------------
 1 file changed, 77 insertions(+), 84 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD    2018-03-14 00:43:40 UTC (rev 307511)
+++ PKGBUILD    2018-03-14 00:43:47 UTC (rev 307512)
@@ -1,84 +0,0 @@
-# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
-
-pkgbase=python-eventlet
-pkgname=('python-eventlet' 'python2-eventlet')
-_pyname=eventlet
-pkgver=0.21.0
-pkgrel=1
-pkgdesc='Highly concurrent networking library'
-url='http://eventlet.net'
-arch=('any')
-license=('MIT')
-makedepends=('python2-pip' 'python-greenlet' 'python-setuptools' 
'python-sphinx' 'python2-greenlet' 'python2-setuptools' 'python2-sphinx' 
'python2-subprocess32')
-checkdepends=('python-psycopg2' 'python-nose' 'python-pyopenssl' 
'python-httplib2' 'python-mock' 'python-pyzmq' 'python-dnspython'
-              'python2-psycopg2' 'python2-nose' 'python2-pyopenssl' 
'python2-httplib2' 'python2-mock' 'python2-pyzmq' 'python2-dnspython')
-source=(${pkgbase}-${pkgver}.tar.gz::https://github.com/eventlet/eventlet/archive/v${pkgver}.tar.gz
-        
${pkgbase}-${pkgver}-fix-monotonic.patch::https://github.com/eventlet/eventlet/commit/82f1877ff5b950e1ee9debbb8be880ebedb8abcb.patch
-        
${pkgbase}-${pkgver}-fix-python2.patch::https://github.com/eventlet/eventlet/commit/2ca03b91c60fc77dbf543ff054425299c310b38e.patch)
-sha512sums=('6f39c32198e275297cad8b932164d15110d9a80fa3c4641caf99571c1229640d1908f4e1a43061957e79bcea1dcf7b78b4236f135e9acf85ebe115c3a9985ca5'
-            
'37df0733526191cc2d4439e52e9a1bcfd9c7843e4b5bb1df8376c97d2c96d92a81591c64a2332fd62501f0754704036e2d427cb6e4bb0ab264e991c074388d16'
-            
'31885e4e04ed5a174c455ad56527051421d4ab138140cb77ca26698f048718c2bd340bdb774e4432d34af4a893543678c5b158ae77d75a8a8c42e2dc6497bd51')
-
-prepare() {
-  (cd ${_pyname}-${pkgver}
-    sed -r 's|(check_idle_cpu_usage\(.*,) .*\)|\1 0.8\)|g' -i tests/*_test.py
-    patch -p1 < "${srcdir}/${pkgbase}-${pkgver}-fix-monotonic.patch"
-    patch -p1 < "${srcdir}/${pkgbase}-${pkgver}-fix-python2.patch"
-  )
-  cp -a ${_pyname}-${pkgver}{,-py2}
-  sed 's|python|python2|' -i ${_pyname}-${pkgver}-py2/examples/*
-}
-
-build() {
-  (cd ${_pyname}-${pkgver}
-    python setup.py build
-    make -C doc text
-  )
-  (cd ${_pyname}-${pkgver}-py2
-    python2 setup.py build
-    make -C doc text
-  )
-}
-
-check() {
-  (cd ${_pyname}-${pkgver}
-    nosetests -sv tests
-  )
-  (cd ${_pyname}-${pkgver}-py2
-    nosetests2 -sv tests
-  )
-}
-
-package_python-eventlet() {
-  depends=('python' 'python-greenlet')
-  optdepends=('python-psycopg2: non-blocking PostgreSQL support'
-              'python-pyopenssl: non-blocking SSL support'
-              'python-httplib2: non-blocking HTTP support'
-              'python-pyzmq: non-blocking ZeroMQ support'
-              'python-dnspython: non-blocking DNS support')
-
-  cd ${_pyname}-${pkgver}
-  python setup.py install --prefix=/usr --root="${pkgdir}" -O1
-  install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
-  install -d "${pkgdir}/usr/share/doc/${pkgname}"
-  cp -r doc/_build/text "${pkgdir}/usr/share/doc/${pkgname}"
-  cp -r examples "${pkgdir}/usr/share/doc/${pkgname}"
-}
-
-package_python2-eventlet() {
-  depends=('python2' 'python2-greenlet' 'python2-subprocess32')
-  optdepends=('python2-psycopg2: non-blocking PostgreSQL support'
-              'python2-pyopenssl: non-blocking SSL support'
-              'python2-httplib2: non-blocking HTTP support'
-              'python2-pyzmq: non-blocking ZeroMQ support'
-              'python2-dnspython: non-blocking DNS support')
-
-  cd ${_pyname}-${pkgver}-py2
-  python2 setup.py install --prefix=/usr --root="${pkgdir}" -O1
-  install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
-  install -d "${pkgdir}/usr/share/doc/${pkgname}"
-  cp -r doc/_build/text "${pkgdir}/usr/share/doc/${pkgname}"
-  cp -r examples "${pkgdir}/usr/share/doc/${pkgname}"
-}
-
-# vim: ts=2 sw=2 et:

Copied: python-eventlet/repos/community-any/PKGBUILD (from rev 307511, 
python-eventlet/trunk/PKGBUILD)
===================================================================
--- PKGBUILD                            (rev 0)
+++ PKGBUILD    2018-03-14 00:43:47 UTC (rev 307512)
@@ -0,0 +1,77 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+
+pkgbase=python-eventlet
+pkgname=('python-eventlet' 'python2-eventlet')
+_pyname=eventlet
+pkgver=0.22.1
+pkgrel=1
+pkgdesc='Highly concurrent networking library'
+url='http://eventlet.net'
+arch=('any')
+license=('MIT')
+makedepends=('python2-pip' 'python-greenlet' 'python-setuptools' 
'python-sphinx' 'python2-greenlet' 'python2-setuptools' 'python2-sphinx' 
'python2-subprocess32')
+checkdepends=('python-psycopg2' 'python-nose' 'python-pyopenssl' 
'python-httplib2' 'python-mock' 'python-pyzmq' 'python-dnspython'
+              'python2-psycopg2' 'python2-nose' 'python2-pyopenssl' 
'python2-httplib2' 'python2-mock' 'python2-pyzmq' 'python2-dnspython')
+options=('!makeflags')
+source=(${pkgbase}-${pkgver}.tar.gz::https://github.com/eventlet/eventlet/archive/v${pkgver}.tar.gz)
+sha512sums=('343fec2ba3669bfaedb56ca3edb9675adf9e86f3590a0c3db5bdd658a0ff6a40234519c6a854c14f91454fb8ee426e6f8291745d1d9a169c80c0dc58cb1fc219')
+
+prepare() {
+  sed -r 's|(check_idle_cpu_usage\(.*,) .*\)|\1 0.8\)|g' -i 
${_pyname}-${pkgver}/tests/*_test.py
+  cp -a ${_pyname}-${pkgver}{,-py2}
+  sed 's|python|python2|' -i ${_pyname}-${pkgver}-py2/examples/*
+}
+
+build() {
+  (cd ${_pyname}-${pkgver}
+    python setup.py build
+    make -C doc text
+  )
+  (cd ${_pyname}-${pkgver}-py2
+    python2 setup.py build
+    make -C doc text
+  )
+}
+
+check() {
+  (cd ${_pyname}-${pkgver}
+    nosetests -sv tests
+  )
+  (cd ${_pyname}-${pkgver}-py2
+    nosetests2 -sv tests
+  )
+}
+
+package_python-eventlet() {
+  depends=('python' 'python-greenlet')
+  optdepends=('python-psycopg2: non-blocking PostgreSQL support'
+              'python-pyopenssl: non-blocking SSL support'
+              'python-httplib2: non-blocking HTTP support'
+              'python-pyzmq: non-blocking ZeroMQ support'
+              'python-dnspython: non-blocking DNS support')
+
+  cd ${_pyname}-${pkgver}
+  python setup.py install --prefix=/usr --root="${pkgdir}" -O1
+  install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+  install -d "${pkgdir}/usr/share/doc/${pkgname}"
+  cp -r doc/_build/text "${pkgdir}/usr/share/doc/${pkgname}"
+  cp -r examples "${pkgdir}/usr/share/doc/${pkgname}"
+}
+
+package_python2-eventlet() {
+  depends=('python2' 'python2-greenlet' 'python2-subprocess32')
+  optdepends=('python2-psycopg2: non-blocking PostgreSQL support'
+              'python2-pyopenssl: non-blocking SSL support'
+              'python2-httplib2: non-blocking HTTP support'
+              'python2-pyzmq: non-blocking ZeroMQ support'
+              'python2-dnspython: non-blocking DNS support')
+
+  cd ${_pyname}-${pkgver}-py2
+  python2 setup.py install --prefix=/usr --root="${pkgdir}" -O1
+  install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+  install -d "${pkgdir}/usr/share/doc/${pkgname}"
+  cp -r doc/_build/text "${pkgdir}/usr/share/doc/${pkgname}"
+  cp -r examples "${pkgdir}/usr/share/doc/${pkgname}"
+}
+
+# vim: ts=2 sw=2 et:

Reply via email to