Date: Saturday, April 7, 2018 @ 18:39:11
  Author: anthraxx
Revision: 314889

archrelease: copy trunk to community-any

Added:
  vim-jedi/repos/community-any/PKGBUILD
    (from rev 314888, vim-jedi/trunk/PKGBUILD)
  vim-jedi/repos/community-any/vim-jedi.install
    (from rev 314888, vim-jedi/trunk/vim-jedi.install)
Deleted:
  vim-jedi/repos/community-any/PKGBUILD
  vim-jedi/repos/community-any/vim-jedi.install

------------------+
 PKGBUILD         |   74 ++++++++++++++++++++++++++++-------------------------
 vim-jedi.install |   38 +++++++++++++--------------
 2 files changed, 59 insertions(+), 53 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD    2018-04-07 18:39:04 UTC (rev 314888)
+++ PKGBUILD    2018-04-07 18:39:11 UTC (rev 314889)
@@ -1,34 +0,0 @@
-# Maintainer: Lukas Fleischer <lfleisc...@archlinux.org>
-# Contributor: Danilo Bargen <gez...@gmail.com>
-
-pkgname=vim-jedi
-_reponame=jedi-vim
-pkgver=0.8.0
-pkgrel=3
-pkgdesc='Vim plugin for jedi, an awesome Python autocompletion.'
-arch=('any')
-url="https://github.com/davidhalter/${_reponame}";
-license=('MIT')
-depends=('vim' 'python-jedi' 'python')
-optdepends=('vim-supertab: for tab completion'
-            'python2-jedi: for Python 2 support')
-groups=('vim-plugins')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/davidhalter/${_reponame}/archive/${pkgver}.tar.gz";)
-sha256sums=('d1f000b8c93c915a1bcc379a4784e68e58192747a6fddc992af04245f68743b6')
-install=${pkgname}.install
-
-package() {
-  cd "$srcdir/$_reponame-$pkgver"
-
-  install -d "${pkgdir}/usr/share/vim/vimfiles/doc"
-
-  cp -dp --no-preserve=ownership jedi_vim.py initialize.py 
"${pkgdir}/usr/share/vim/vimfiles/"
-  cp -dp --no-preserve=ownership doc/jedi-vim.txt 
"${pkgdir}/usr/share/vim/vimfiles/doc/"
-  cp -dpr --no-preserve=ownership after 
"${pkgdir}/usr/share/vim/vimfiles/after"
-  cp -dpr --no-preserve=ownership autoload 
"${pkgdir}/usr/share/vim/vimfiles/autoload"
-  cp -dpr --no-preserve=ownership ftplugin 
"${pkgdir}/usr/share/vim/vimfiles/ftplugin"
-  cp -dpr --no-preserve=ownership plugin 
"${pkgdir}/usr/share/vim/vimfiles/plugin"
-
-  # install license file
-  install -Dm0644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}

Copied: vim-jedi/repos/community-any/PKGBUILD (from rev 314888, 
vim-jedi/trunk/PKGBUILD)
===================================================================
--- PKGBUILD                            (rev 0)
+++ PKGBUILD    2018-04-07 18:39:11 UTC (rev 314889)
@@ -0,0 +1,40 @@
+# Maintainer: Lukas Fleischer <lfleisc...@archlinux.org>
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Danilo Bargen <gez...@gmail.com>
+
+pkgname=vim-jedi
+_reponame=jedi-vim
+pkgver=0.9.0
+pkgrel=1
+pkgdesc='Vim plugin for jedi, an awesome Python autocompletion'
+arch=('any')
+url="https://github.com/davidhalter/jedi-vim";
+license=('MIT')
+depends=('vim' 'python-jedi' 'python')
+optdepends=('vim-supertab: tab completion'
+            'python2-jedi: Python 2 support')
+checkdepends=('python-pytest')
+groups=('vim-plugins')
+options=('!emptydirs')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/davidhalter/${_reponame}/archive/${pkgver}.tar.gz)
+sha256sums=('e53ef98472dd4789d5382f5082c0c25bf713264422389fca2f2a9bcddc1435d5')
+install=${pkgname}.install
+
+check() {
+  cd ${_reponame}-${pkgver}
+  py.test
+}
+
+package() {
+  cd ${_reponame}-${pkgver}
+
+  install -d "${pkgdir}/usr/share/vim/vimfiles"
+  cp -dpr --no-preserve=ownership pythonx "${pkgdir}/usr/share/vim/vimfiles"
+  cp -dpr --no-preserve=ownership doc "${pkgdir}/usr/share/vim/vimfiles/doc"
+  cp -dpr --no-preserve=ownership after 
"${pkgdir}/usr/share/vim/vimfiles/after"
+  cp -dpr --no-preserve=ownership autoload 
"${pkgdir}/usr/share/vim/vimfiles/autoload"
+  cp -dpr --no-preserve=ownership ftplugin 
"${pkgdir}/usr/share/vim/vimfiles/ftplugin"
+  cp -dpr --no-preserve=ownership plugin 
"${pkgdir}/usr/share/vim/vimfiles/plugin"
+
+  install -Dm 644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}

Deleted: vim-jedi.install
===================================================================
--- vim-jedi.install    2018-04-07 18:39:04 UTC (rev 314888)
+++ vim-jedi.install    2018-04-07 18:39:11 UTC (rev 314889)
@@ -1,19 +0,0 @@
-warn_nopy3() {
-       py3grep=`vim --version | grep "\+python3"`
-    if [ ${#py3grep} -le 1 ]
-    then
-        echo "-----------------------------------------------------"
-        echo -e "\e[1mWarning:\e[m"
-        echo "Your vim install doesn't seem to support Python 3."
-        echo "If that's the case you should install the python2 and 
python2-jedi packages."
-        echo "-----------------------------------------------------"
-    fi
-}
-
-post_install() {
-    warn_nopy3
-}
-
-post_upgrade() {
-    warn_nopy3
-}

Copied: vim-jedi/repos/community-any/vim-jedi.install (from rev 314888, 
vim-jedi/trunk/vim-jedi.install)
===================================================================
--- vim-jedi.install                            (rev 0)
+++ vim-jedi.install    2018-04-07 18:39:11 UTC (rev 314889)
@@ -0,0 +1,19 @@
+warn_nopy3() {
+       py3grep=`vim --version | grep "\+python3"`
+    if [ ${#py3grep} -le 1 ]
+    then
+        echo "-----------------------------------------------------"
+        echo -e "\e[1mWarning:\e[m"
+        echo "Your vim install doesn't seem to support Python 3."
+        echo "If that's the case you should install the python2 and 
python2-jedi packages."
+        echo "-----------------------------------------------------"
+    fi
+}
+
+post_install() {
+    warn_nopy3
+}
+
+post_upgrade() {
+    warn_nopy3
+}

Reply via email to