Date: Monday, April 9, 2018 @ 22:15:03
  Author: dvzrv
Revision: 315498

archrelease: copy trunk to community-x86_64

Added:
  supercollider/repos/community-x86_64/PKGBUILD
    (from rev 315497, supercollider/trunk/PKGBUILD)
  supercollider/repos/community-x86_64/supercollider.install
    (from rev 315497, supercollider/trunk/supercollider.install)
Deleted:
  
supercollider/repos/community-x86_64/0001-cmake-correctly-include-yaml-cpp.patch
  
supercollider/repos/community-x86_64/0002-set-YAMLCPP_LIBRARY-and-YAMLCPP_INCLUDE_DIR-if-not-u.patch
  supercollider/repos/community-x86_64/PKGBUILD
  supercollider/repos/community-x86_64/supercollider.install

-----------------------------------------------------------------+
 0001-cmake-correctly-include-yaml-cpp.patch                     |   57 -----
 0002-set-YAMLCPP_LIBRARY-and-YAMLCPP_INCLUDE_DIR-if-not-u.patch |   26 --
 PKGBUILD                                                        |  103 
++++------
 supercollider.install                                           |   16 -
 4 files changed, 55 insertions(+), 147 deletions(-)

Deleted: 0001-cmake-correctly-include-yaml-cpp.patch
===================================================================
--- 0001-cmake-correctly-include-yaml-cpp.patch 2018-04-09 22:14:56 UTC (rev 
315497)
+++ 0001-cmake-correctly-include-yaml-cpp.patch 2018-04-09 22:15:03 UTC (rev 
315498)
@@ -1,57 +0,0 @@
-From f82cec5ae917e4d43a2a003b2eb0ddae3c0d31c7 Mon Sep 17 00:00:00 2001
-From: Brian Heim <brianlh...@gmail.com>
-Date: Sun, 4 Mar 2018 18:29:54 -0500
-Subject: [PATCH 1/2] cmake: correctly include yaml-cpp
-
-Include its dirs last for libsclang, and use the YAMLCPP_LIBRARY variable for 
linking
----
- editors/sc-ide/CMakeLists.txt | 3 ++-
- lang/CMakeLists.txt           | 4 ++--
- 2 files changed, 4 insertions(+), 3 deletions(-)
-
-diff --git a/editors/sc-ide/CMakeLists.txt b/editors/sc-ide/CMakeLists.txt
-index ffe70f98e..2f6c9c2cc 100644
---- a/editors/sc-ide/CMakeLists.txt
-+++ b/editors/sc-ide/CMakeLists.txt
-@@ -199,6 +199,7 @@ include_directories(${CMAKE_SOURCE_DIR}/include/common)
- include_directories(${CMAKE_SOURCE_DIR}/common)
- include_directories(${CMAKE_SOURCE_DIR}/include/plugin_interface)
- include_directories(${CMAKE_SOURCE_DIR}/external_libraries/boost)
-+include_directories(${YAMLCPP_INCLUDE_DIR})
- # For QtCollider headers:
- include_directories(${CMAKE_SOURCE_DIR})
- # Needed for auto-generated forms headers:
-@@ -273,7 +274,7 @@ endif()
- 
- target_link_libraries( SuperCollider
-     ${QT_IDE_LIBRARIES}
--    yaml
-+    ${YAMLCPP_LIBRARY}
-     oscpack
- )
- 
-diff --git a/lang/CMakeLists.txt b/lang/CMakeLists.txt
-index 9270b6320..5de19e46e 100644
---- a/lang/CMakeLists.txt
-+++ b/lang/CMakeLists.txt
-@@ -10,8 +10,6 @@ include_directories(${CMAKE_SOURCE_DIR}/include/common
-                     ${CMAKE_SOURCE_DIR}/include/server
-                     ${CMAKE_SOURCE_DIR}/common
- 
--                    ${YAMLCPP_INCLUDE_DIR}
--
-                     ${CMAKE_SOURCE_DIR}/external_libraries/boost_sync/include
- 
-                     LangSource
-@@ -19,6 +17,8 @@ include_directories(${CMAKE_SOURCE_DIR}/include/common
- 
-                     ${CMAKE_SOURCE_DIR}/external_libraries/nova-tt
-                     LangSource/Bison
-+
-+                    ${YAMLCPP_INCLUDE_DIR}
- )
- 
- 
--- 
-2.16.2
-

Deleted: 0002-set-YAMLCPP_LIBRARY-and-YAMLCPP_INCLUDE_DIR-if-not-u.patch
===================================================================
--- 0002-set-YAMLCPP_LIBRARY-and-YAMLCPP_INCLUDE_DIR-if-not-u.patch     
2018-04-09 22:14:56 UTC (rev 315497)
+++ 0002-set-YAMLCPP_LIBRARY-and-YAMLCPP_INCLUDE_DIR-if-not-u.patch     
2018-04-09 22:15:03 UTC (rev 315498)
@@ -1,26 +0,0 @@
-From 031922987a1fea903ecc908d1b40d696823f1f28 Mon Sep 17 00:00:00 2001
-From: Brian Heim <brianlh...@gmail.com>
-Date: Sun, 4 Mar 2018 18:48:42 -0500
-Subject: [PATCH 2/2] set YAMLCPP_LIBRARY and YAMLCPP_INCLUDE_DIR if not using
- system
-
----
- external_libraries/CMakeLists.txt | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/external_libraries/CMakeLists.txt 
b/external_libraries/CMakeLists.txt
-index 10c466fd4..df33dc6f1 100644
---- a/external_libraries/CMakeLists.txt
-+++ b/external_libraries/CMakeLists.txt
-@@ -106,6 +106,8 @@ if(NOT YAMLCPP_FOUND)
-   add_library(yaml STATIC EXCLUDE_FROM_ALL 
${CMAKE_CURRENT_BINARY_DIR}/libyamlcpp.cpp)
-   target_include_directories(yaml PUBLIC 
${CMAKE_SOURCE_DIR}/external_libraries/yaml-cpp/include boost)
-   set_property( TARGET yaml PROPERTY FOLDER 3rdparty )
-+  set(YAMLCPP_LIBRARY yaml)
-+  set(YAMLCPP_INCLUDE_DIR 
${CMAKE_SOURCE_DIR}/external_libraries/yaml-cpp/include)
- 
-   if(CMAKE_COMPILER_IS_GNUCXX)
-     target_compile_options(yaml PRIVATE -Wno-deprecated-declarations)
--- 
-2.16.2
-

Deleted: PKGBUILD
===================================================================
--- PKGBUILD    2018-04-09 22:14:56 UTC (rev 315497)
+++ PKGBUILD    2018-04-09 22:15:03 UTC (rev 315498)
@@ -1,56 +0,0 @@
-# $Id$
-# Maintainer: David Runge <d...@sleepmap.de>
-# Contributor: speps <speps at aur dot archlinux dot org>
-# Contributor: osc <farid at archlinux-br.org>
-
-_name=SuperCollider
-pkgname=supercollider
-pkgver=3.9.2
-pkgrel=1
-pkgdesc="An environment and programming language for real time audio synthesis 
and algorithmic composition"
-arch=('x86_64')
-url="https://supercollider.github.io";
-license=('GPL3')
-depends=('boost-libs' 'fftw' 'jack' 'qt5-webkit' 'yaml-cpp')
-makedepends=('boost' 'cmake' 'emacs' 'qt5-tools')
-optdepends=('emacs: emacs interface'
-            'gedit: gedit interface'
-            'sc3-plugins: additional extension plugins for scsynth')
-source=("https://github.com/${pkgname}/${pkgname}/releases/download/Version-${pkgver}/${_name}-${pkgver}-Source-linux.tar.bz2";
-        '0001-cmake-correctly-include-yaml-cpp.patch'
-        '0002-set-YAMLCPP_LIBRARY-and-YAMLCPP_INCLUDE_DIR-if-not-u.patch')
-install="${pkgname}.install"
-sha512sums=('363a36242a4e3a82477719c018765450ce79d1ba601d7ab625f557cd9c1e9402dff43f7adb468453f1ecc4106116c4270f9f929abcf80fdd59855aa5d48b9db2'
-            
'd4204b8c8ce12b383b39f96e9a9f36ee71a36ddfba019cdf0454ffa8170681bd38b688e41c6e5910f087ad13b3021f59dc2c0c825a500c57364b04fb5d90af30'
-            
'be587ee652c652f2a19a68d06ca62cae5c5f6c5d4d3a5777723e1aba319e859ede418010345b7a4b0fe8d02dc70528fec7f4479dce259914f2d57d46d9ad659f')
-
-prepare() {
-  mv -v "${_name}-Source" "${pkgname}-${pkgver}"
-  cd "${pkgname}-${pkgver}"
-  # fixing yaml-cpp include:
-  # https://github.com/supercollider/supercollider/issues/3557
-  patch -Np1 -i ../0001-cmake-correctly-include-yaml-cpp.patch
-  patch -Np1 -i \
-    ../0002-set-YAMLCPP_LIBRARY-and-YAMLCPP_INCLUDE_DIR-if-not-u.patch
-  # requires out-of-tree build
-  mkdir -v bld
-}
-
-build() {
-  cd "${pkgname}-${pkgver}/bld"
-  cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
-           -DCMAKE_BUILD_TYPE=Release \
-           -DLIBSCSYNTH=ON \
-           -DFORTIFY=ON \
-           -DSYSTEM_BOOST=ON \
-           -DSYSTEM_YAMLCPP=ON \
-           -DSC_VIM=OFF
-  make
-}
-
-package() {
-  cd "${pkgname}-${pkgver}/bld"
-  make DESTDIR="${pkgdir}" install
-  install -t "${pkgdir}/usr/share/doc/${pkgname}/" \
-    -vDm 644 ../{AUTHORS,{CHANGELOG,README,README_LINUX}.md}
-}

Copied: supercollider/repos/community-x86_64/PKGBUILD (from rev 315497, 
supercollider/trunk/PKGBUILD)
===================================================================
--- PKGBUILD                            (rev 0)
+++ PKGBUILD    2018-04-09 22:15:03 UTC (rev 315498)
@@ -0,0 +1,47 @@
+# $Id$
+# Maintainer: David Runge <d...@sleepmap.de>
+# Contributor: speps <speps at aur dot archlinux dot org>
+# Contributor: osc <farid at archlinux-br.org>
+
+_name=SuperCollider
+pkgname=supercollider
+pkgver=3.9.3
+pkgrel=1
+pkgdesc="An environment and programming language for real time audio synthesis 
and algorithmic composition"
+arch=('x86_64')
+url="https://supercollider.github.io";
+license=('GPL3')
+depends=('boost-libs' 'fftw' 'jack' 'qt5-webkit' 'yaml-cpp')
+makedepends=('boost' 'cmake' 'emacs' 'qt5-tools')
+optdepends=('emacs: emacs interface'
+            'gedit: gedit interface'
+            'sc3-plugins: additional extension plugins for scsynth')
+source=("https://github.com/${pkgname}/${pkgname}/releases/download/Version-${pkgver}/${_name}-${pkgver}-Source-linux.tar.bz2";)
+install="${pkgname}.install"
+sha512sums=('5b0c29941907d5ca45c1676e34184664c03891051bba0ee50d9e8311400824054de7b6daba6d29fd875ff38f42ee9654504ea2f0b5bf0a36ae9605e6a79a0841')
+
+prepare() {
+  mv -v "${_name}-Source" "${pkgname}-${pkgver}"
+  cd "${pkgname}-${pkgver}"
+  # requires out-of-tree build
+  mkdir -v bld
+}
+
+build() {
+  cd "${pkgname}-${pkgver}/bld"
+  cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+           -DCMAKE_BUILD_TYPE=Release \
+           -DLIBSCSYNTH=ON \
+           -DFORTIFY=ON \
+           -DSYSTEM_BOOST=ON \
+           -DSYSTEM_YAMLCPP=ON \
+           -DSC_VIM=OFF
+  make
+}
+
+package() {
+  cd "${pkgname}-${pkgver}/bld"
+  make DESTDIR="${pkgdir}" install
+  install -t "${pkgdir}/usr/share/doc/${pkgname}/" \
+    -vDm 644 ../{AUTHORS,{CHANGELOG,README,README_LINUX}.md}
+}

Deleted: supercollider.install
===================================================================
--- supercollider.install       2018-04-09 22:14:56 UTC (rev 315497)
+++ supercollider.install       2018-04-09 22:15:03 UTC (rev 315498)
@@ -1,8 +0,0 @@
-post_install () {
-  echo "The vim plugin 'SCVim' is now developed separately: 
https://github.com/supercollider/scvim";
-  echo "Until a package is provided, please use the install methods mentioned 
in the link."
-}
-
-post_upgrade () {
-  post_install
-}

Copied: supercollider/repos/community-x86_64/supercollider.install (from rev 
315497, supercollider/trunk/supercollider.install)
===================================================================
--- supercollider.install                               (rev 0)
+++ supercollider.install       2018-04-09 22:15:03 UTC (rev 315498)
@@ -0,0 +1,8 @@
+post_install () {
+  echo "The vim plugin 'SCVim' is now developed separately: 
https://github.com/supercollider/scvim";
+  echo "Until a package is provided, please use the install methods mentioned 
in the link."
+}
+
+post_upgrade () {
+  post_install
+}

Reply via email to