Date: Tuesday, April 10, 2018 @ 09:26:21
  Author: heftig
Revision: 315547

archrelease: copy trunk to community-x86_64

Added:
  gnome-software/repos/community-x86_64/PKGBUILD
    (from rev 315545, gnome-software/trunk/PKGBUILD)
Deleted:
  gnome-software/repos/community-x86_64/PKGBUILD

----------+
 PKGBUILD |  114 ++++++++++++++++++++++++++++++-------------------------------
 1 file changed, 57 insertions(+), 57 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD    2018-04-10 09:26:17 UTC (rev 315546)
+++ PKGBUILD    2018-04-10 09:26:21 UTC (rev 315547)
@@ -1,57 +0,0 @@
-# $Id$
-# Maintainer: Jan Alexander Steffens (heftig) <jan.steff...@gmail.com>
-# Contributor: Jan de Groot <j...@archlinux.org>
-# Contributor: Yosef Or Boczko <yosef...@gnome.org>
-
-pkgbase=gnome-software
-pkgname=(gnome-software gnome-software-packagekit-plugin)
-pkgver=3.28.0
-pkgrel=1
-pkgdesc="GNOME Software Tools"
-url="https://wiki.gnome.org/Apps/Software/";
-arch=(x86_64)
-license=(GPL2)
-makedepends=(appstream-glib gnome-desktop gtkspell3 libpackagekit-glib flatpak 
fwupd ostree
-             docbook-xsl git gobject-introspection gtk-doc meson valgrind 
gspell)
-_commit=299554f4a23e39f5d0b0e4d8f59a4beb2954ffa0  # tags/3.28.0^0
-source=("git+https://gitlab.gnome.org/GNOME/gnome-software.git#commit=$_commit";)
-sha256sums=('SKIP')
-
-pkgver() {
-  cd $pkgbase
-  git describe --tags | sed 's/^GNOME_SOFTWARE_//;s/_/./g;s/-/+/g'
-}
-
-prepare() {
-  cd $pkgbase
-}
-
-build() {
-  arch-meson $pkgbase build \
-    -D enable-rpm=false \
-    -D enable-ubuntuone=false \
-    -D enable-ubuntu-reviews=false
-  ninja -C build
-}
-
-package_gnome-software() {
-  groups=('gnome')
-  depends=(appstream-glib gnome-desktop gsettings-desktop-schemas gtkspell3 
libpackagekit-glib gspell)
-  optdepends=('flatpak: Flatpak support plugin'
-              'fwupd: fwupd support plugin'
-              'ostree: OSTree support plugin')
-
-  DESTDIR="$pkgdir" ninja -C build install
-
-  # Split out packagekit plugin
-  mkdir "$srcdir"/packagekit-plugin
-  mv 
"$pkgdir"/usr/lib/gs-plugins-11/libgs_plugin_{packagekit*,systemd-updates}.so 
"$srcdir"/packagekit-plugin
-}
-
-package_gnome-software-packagekit-plugin() {
-  pkgdesc="PackageKit support plugin for GNOME Software"
-  depends=(archlinux-appstream-data gnome-software packagekit)
-
-  mkdir -p "$pkgdir"/usr/lib/gs-plugins-11
-  mv "$srcdir"/packagekit-plugin/* "$pkgdir"/usr/lib/gs-plugins-11/
-}

Copied: gnome-software/repos/community-x86_64/PKGBUILD (from rev 315545, 
gnome-software/trunk/PKGBUILD)
===================================================================
--- PKGBUILD                            (rev 0)
+++ PKGBUILD    2018-04-10 09:26:21 UTC (rev 315547)
@@ -0,0 +1,57 @@
+# $Id$
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steff...@gmail.com>
+# Contributor: Jan de Groot <j...@archlinux.org>
+# Contributor: Yosef Or Boczko <yosef...@gnome.org>
+
+pkgbase=gnome-software
+pkgname=(gnome-software gnome-software-packagekit-plugin)
+pkgver=3.28.1
+pkgrel=1
+pkgdesc="GNOME Software Tools"
+url="https://wiki.gnome.org/Apps/Software/";
+arch=(x86_64)
+license=(GPL2)
+makedepends=(appstream-glib gnome-desktop gtkspell3 libpackagekit-glib flatpak 
fwupd ostree
+             docbook-xsl git gobject-introspection gtk-doc meson valgrind 
gspell)
+_commit=59160c4d7726f46f726da3002713daec5e50aa2e  # tags/3.28.1^0
+source=("git+https://gitlab.gnome.org/GNOME/gnome-software.git#commit=$_commit";)
+sha256sums=('SKIP')
+
+pkgver() {
+  cd $pkgbase
+  git describe --tags | sed 's/^GNOME_SOFTWARE_//;s/_/./g;s/-/+/g'
+}
+
+prepare() {
+  cd $pkgbase
+}
+
+build() {
+  arch-meson $pkgbase build \
+    -D enable-rpm=false \
+    -D enable-ubuntuone=false \
+    -D enable-ubuntu-reviews=false
+  ninja -C build
+}
+
+package_gnome-software() {
+  groups=('gnome')
+  depends=(appstream-glib gnome-desktop gsettings-desktop-schemas gtkspell3 
libpackagekit-glib gspell)
+  optdepends=('flatpak: Flatpak support plugin'
+              'fwupd: fwupd support plugin'
+              'ostree: OSTree support plugin')
+
+  DESTDIR="$pkgdir" ninja -C build install
+
+  # Split out packagekit plugin
+  mkdir "$srcdir"/packagekit-plugin
+  mv 
"$pkgdir"/usr/lib/gs-plugins-11/libgs_plugin_{packagekit*,systemd-updates}.so 
"$srcdir"/packagekit-plugin
+}
+
+package_gnome-software-packagekit-plugin() {
+  pkgdesc="PackageKit support plugin for GNOME Software"
+  depends=(archlinux-appstream-data gnome-software packagekit)
+
+  mkdir -p "$pkgdir"/usr/lib/gs-plugins-11
+  mv "$srcdir"/packagekit-plugin/* "$pkgdir"/usr/lib/gs-plugins-11/
+}

Reply via email to