Date: Wednesday, May 16, 2018 @ 07:53:38
  Author: eworm
Revision: 322566

archrelease: copy trunk to community-testing-x86_64

Added:
  libcurl-compat/repos/community-testing-x86_64/
  libcurl-compat/repos/community-testing-x86_64/PKGBUILD
    (from rev 322565, libcurl-compat/trunk/PKGBUILD)

----------+
 PKGBUILD |   54 ++++++++++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 54 insertions(+)

Copied: libcurl-compat/repos/community-testing-x86_64/PKGBUILD (from rev 
322565, libcurl-compat/trunk/PKGBUILD)
===================================================================
--- community-testing-x86_64/PKGBUILD                           (rev 0)
+++ community-testing-x86_64/PKGBUILD   2018-05-16 07:53:38 UTC (rev 322566)
@@ -0,0 +1,54 @@
+# $Id$
+# Maintainer: Maxime Gauduin <aluc...@archlinux.org>
+# Contributor: Piotr Balcerowski <pi...@balcerowski.org>
+
+pkgname=libcurl-compat
+pkgver=7.60.0
+pkgrel=1
+pkgdesc='An URL retrieval library (without versioned symbols)'
+arch=('x86_64')
+url='https://curl.haxx.se'
+license=('MIT')
+depends=('curl' 'glibc' 'krb5' 'openssl' 'libpsl' 'zlib'
+         'libssh2.so')
+options=('strip')
+source=("https://curl.haxx.se/download/curl-${pkgver}.tar.gz"{,.asc})
+validpgpkeys=('27EDEAF22F3ABCEB50DB9A125CC908FDB71E12C2') # Daniel Stenberg
+sha512sums=('f25c8d79be87bfbcae93cd200b319f664efd62aea8f1a94bb441407a9e1489bd935943cfd1347f3b252f94b9a0286da8aeb04b407a2ba95ebfa717dff80e891b'
+            'SKIP')
+
+build() {
+  cd curl-${pkgver}
+
+  ./configure \
+    --prefix='/usr' \
+    --disable-ldap \
+    --disable-ldaps \
+    --disable-manual \
+    --disable-versioned-symbols \
+    --enable-ipv6 \
+    --enable-threaded-resolver \
+    --with-gssapi \
+    --with-random='/dev/urandom' \
+    --with-ca-bundle='/etc/ssl/certs/ca-certificates.crt'
+
+  sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+  make -C lib
+}
+
+package() {
+  cd curl-${pkgver}
+
+  make -C lib DESTDIR="${pkgdir}" install
+
+  mv "${pkgdir}"/usr/lib/libcurl{,-compat}.so.4.5.0
+  rm "${pkgdir}"/usr/lib/libcurl.{a,so}*
+  for version in 3 4.0.0 4.1.0 4.2.0 4.3.0 4.4.0; do
+    ln -s libcurl-compat.so.4.5.0 "${pkgdir}"/usr/lib/libcurl.so.${version}
+  done
+
+  install -dm 755 "${pkgdir}"/usr/share/licenses
+  ln -s curl "${pkgdir}"/usr/share/licenses/libcurl-compat
+}
+
+# vim: ts=2 sw=2 et:

Reply via email to