Date: Saturday, August 11, 2018 @ 17:01:26
  Author: aginiewicz
Revision: 371153

archrelease: copy trunk to community-any

Added:
  python-google-api-python-client/repos/community-any/PKGBUILD
    (from rev 371152, python-google-api-python-client/trunk/PKGBUILD)
Deleted:
  python-google-api-python-client/repos/community-any/PKGBUILD

----------+
 PKGBUILD |  130 ++++++++++++++++++++++++++++++-------------------------------
 1 file changed, 65 insertions(+), 65 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD    2018-08-11 17:01:23 UTC (rev 371152)
+++ PKGBUILD    2018-08-11 17:01:26 UTC (rev 371153)
@@ -1,65 +0,0 @@
-# $Id$
-# Maintainer: Andrzej Giniewicz <ggi...@gmail.com>
-# Contributor: shadyabhi <abhijeet.1...@gmail.com>
-
-pkgbase=python-google-api-python-client
-pkgname=('python2-google-api-python-client' 'python-google-api-python-client')
-pkgver=1.7.3
-pkgrel=2
-pkgdesc="Google API Client Library for Python"
-arch=('any')
-url="https://github.com/google/google-api-python-client";
-license=('Apache')
-makedepends=('python2-setuptools' 'python-setuptools'
-             'python2-google-auth-httplib2' 'python2-uritemplate'
-            'python-google-auth-httplib2' 'python-uritemplate')
-source=("https://github.com/google/google-api-python-client/archive/v${pkgver}.tar.gz";)
-md5sums=('4b6f8ff320e41e920fc2240ae667fb18')
-
-prepare() {
-  cd "$srcdir"
-  cp -a google-api-python-client-${pkgver} 
google-api-python-client-py2-${pkgver}
-  cd google-api-python-client-py2-${pkgver}
-
-  sed -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
-      -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
-      -e "s|#![ ]*/bin/env python$|#!/usr/bin/env python2|" \
-      -i $(find . -name '*.py')
-}
-
-build() {
-  cd "$srcdir/google-api-python-client-$pkgver"
-
-  msg "Building Python2"
-  cd "$srcdir"/google-api-python-client-py2-${pkgver}
-  python2 setup.py build
-
-  msg "Building Python3"
-  cd "$srcdir"/google-api-python-client-${pkgver}
-  python setup.py build
-}
- 
-package_python2-google-api-python-client() {
-  depends=('python2-google-auth-httplib2' 'python2-uritemplate')
-  optdepends=('python2-oauth2client: optional backend')
-  cd "$srcdir/google-api-python-client-py2-$pkgver"
- 
-  python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
-
-  # Workaround for FS#47243
-  _site_packages=`python2 -c "from distutils.sysconfig import get_python_lib; 
print(get_python_lib())"`
-  chmod -R a+r "$pkgdir$_site_packages"
-}
-
-package_python-google-api-python-client() {
-  depends=('python-google-auth-httplib2' 'python-uritemplate')
-  optdepends=('python-oauth2client: optional backend')
-  cd "$srcdir/google-api-python-client-$pkgver"
- 
-  python setup.py install --skip-build --root="$pkgdir" --optimize=1
-
-  # Workaround for FS#47243
-  _site_packages=`python -c "from distutils.sysconfig import get_python_lib; 
print(get_python_lib())"`
-  chmod -R a+r "$pkgdir$_site_packages"
-}
-

Copied: python-google-api-python-client/repos/community-any/PKGBUILD (from rev 
371152, python-google-api-python-client/trunk/PKGBUILD)
===================================================================
--- PKGBUILD                            (rev 0)
+++ PKGBUILD    2018-08-11 17:01:26 UTC (rev 371153)
@@ -0,0 +1,65 @@
+# $Id$
+# Maintainer: Andrzej Giniewicz <ggi...@gmail.com>
+# Contributor: shadyabhi <abhijeet.1...@gmail.com>
+
+pkgbase=python-google-api-python-client
+pkgname=('python2-google-api-python-client' 'python-google-api-python-client')
+pkgver=1.7.4
+pkgrel=1
+pkgdesc="Google API Client Library for Python"
+arch=('any')
+url="https://github.com/google/google-api-python-client";
+license=('Apache')
+makedepends=('python2-setuptools' 'python-setuptools'
+             'python2-google-auth-httplib2' 'python2-uritemplate'
+            'python-google-auth-httplib2' 'python-uritemplate')
+source=("https://github.com/google/google-api-python-client/archive/v${pkgver}.tar.gz";)
+md5sums=('0a693cf52048797273f7a57afde5dd8b')
+
+prepare() {
+  cd "$srcdir"
+  cp -a google-api-python-client-${pkgver} 
google-api-python-client-py2-${pkgver}
+  cd google-api-python-client-py2-${pkgver}
+
+  sed -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
+      -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+      -e "s|#![ ]*/bin/env python$|#!/usr/bin/env python2|" \
+      -i $(find . -name '*.py')
+}
+
+build() {
+  cd "$srcdir/google-api-python-client-$pkgver"
+
+  msg "Building Python2"
+  cd "$srcdir"/google-api-python-client-py2-${pkgver}
+  python2 setup.py build
+
+  msg "Building Python3"
+  cd "$srcdir"/google-api-python-client-${pkgver}
+  python setup.py build
+}
+ 
+package_python2-google-api-python-client() {
+  depends=('python2-google-auth-httplib2' 'python2-uritemplate')
+  optdepends=('python2-oauth2client: optional backend')
+  cd "$srcdir/google-api-python-client-py2-$pkgver"
+ 
+  python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
+
+  # Workaround for FS#47243
+  _site_packages=`python2 -c "from distutils.sysconfig import get_python_lib; 
print(get_python_lib())"`
+  chmod -R a+r "$pkgdir$_site_packages"
+}
+
+package_python-google-api-python-client() {
+  depends=('python-google-auth-httplib2' 'python-uritemplate')
+  optdepends=('python-oauth2client: optional backend')
+  cd "$srcdir/google-api-python-client-$pkgver"
+ 
+  python setup.py install --skip-build --root="$pkgdir" --optimize=1
+
+  # Workaround for FS#47243
+  _site_packages=`python -c "from distutils.sysconfig import get_python_lib; 
print(get_python_lib())"`
+  chmod -R a+r "$pkgdir$_site_packages"
+}
+

Reply via email to