Date: Saturday, August 11, 2018 @ 17:21:10
  Author: aginiewicz
Revision: 371163

upgpkg: python-pyface 6.0.0-3

python-pyfrace: update dependencies for Qt5 (FS#59066)

Modified:
  python-pyface/trunk/PKGBUILD

----------+
 PKGBUILD |   14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD    2018-08-11 17:12:24 UTC (rev 371162)
+++ PKGBUILD    2018-08-11 17:21:10 UTC (rev 371163)
@@ -7,7 +7,7 @@
 pkgbase=python-pyface
 pkgname=('python2-pyface' 'python-pyface')
 pkgver=6.0.0
-pkgrel=2
+pkgrel=3
 pkgdesc="Traits-capable windowing framework"
 arch=('any')
 url="https://github.com/enthought/pyface";
@@ -38,12 +38,11 @@
 
 package_python2-pyface() {
   depends=('python2-traits')
-  optdepends=('python2-pyqt4: for Qt backend (or python2-pyside)'
-              'python2-pyside: for Qt backend (or python2-pyqt4)'
+  optdepends=('python2-pyqt5: for Qt backend'
               'python2-pygments: for syntax coloring in Qt backend'
               'python2-setuptools: to locate resources inside zip and egg 
files'
               'ipython2: for IPython widget'
-              'wxpython: for wx backend')
+              'python2-wxpython3: for wx backend')
 
   cd "$srcdir"/pyface-py2-$pkgver
 
@@ -54,11 +53,12 @@
 
 package_python-pyface() {
   depends=('python-traits')
-  optdepends=('python-pyqt4: for Qt backend (or python2-pyside)'
-              'python-pyside: for Qt backend (or python2-pyqt4)'
+  optdepends=('python-pyqt5: for Qt backend (or pyside2)'
+              'pyside2: for Qt backend (or python-pyqt5)'
               'python-pygments: for syntax coloring in Qt backend'
               'python-setuptools: to locate resources inside zip and egg files'
-              'ipython: for IPython widget')
+              'ipython: for IPython widget'
+             'python-wxpython: for wx backend')
 
   cd "$srcdir"/pyface-$pkgver
 

Reply via email to