Date: Thursday, August 15, 2019 @ 08:49:17
  Author: dvzrv
Revision: 499525

upgpkg: ruby-rugged 0.28.3-1

Upgrading to 0.28.3. Adding fix to import the correct version of the gem (YOLO 
upstream).

Modified:
  ruby-rugged/trunk/PKGBUILD

----------+
 PKGBUILD |   13 ++++++++-----
 1 file changed, 8 insertions(+), 5 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD    2019-08-15 07:22:39 UTC (rev 499524)
+++ PKGBUILD    2019-08-15 08:49:17 UTC (rev 499525)
@@ -3,9 +3,10 @@
 # Contributor: Andy Weidenbaum <archb...@gmail.com>
 
 _name=rugged
-_libgit2_pkgver=0.28.2
+# ideally this should match $pkgver, as package() might fail otherwise. 
thanks, github
+_libgit2_pkgver=0.28.3
 pkgname=ruby-rugged
-pkgver=0.28.2
+pkgver=0.28.3
 pkgrel=1
 pkgdesc='A Ruby binding to the libgit2 linkable library'
 arch=('x86_64')
@@ -17,8 +18,8 @@
 options=(!emptydirs)
 
source=("${_name}-${pkgver}.tar.gz::https://github.com/libgit2/${_name}/archive/v${pkgver}.tar.gz";
         
"libgit2-${_libgit2_pkgver}.tar.gz::https://github.com/libgit2/libgit2/archive/v${_libgit2_pkgver}.tar.gz";)
-sha512sums=('febbccc04d16659ed6866f3c7bae0ba3a2f22937fc827535f3e99c1461b3ae22cf8d676436a09ae7c7a47f3f90eec9787a0afa776bccebc5a659b56b1f78ceed'
-            
'0879c162e2e1dc00eadfbda22cd1f9d3a95b4ec2b653c108983f37c2f695140882de4d50d7cbc04ced247125a4e9fe6df16130e1267891aecdb2411d920db5c6')
+sha512sums=('f377653fb84326968f1126177b0cc6279da5e5f74529605087af7b0c481d203c22d89ca26105dc871ce197c1f91c7fa03cae24fb20d14b65f7002ec017a0e4fe'
+            
'15444823b7d4885f7b8c3982f8905efc4a75913de016a9b2e0a24d5ce9746e6a549dffd5469036529557feff2ce7ece9328266eb312c80b96091ce0f65ee97ee')
 
 prepare() {
   mv -v "${_name}-${pkgver}" "${pkgname}-${pkgver}"
@@ -28,6 +29,9 @@
   # remove broken and useless libgit2 "version check":
   # https://github.com/libgit2/rugged/issues/698
   sed '68,88d' -i ext/rugged/extconf.rb
+  # imported version is wrong:
+  # https://github.com/libgit2/rugged/issues/776#issuecomment-521234453
+  sed -E "s|(VERSION =) .+|\1 '${pkgver}'|" -i lib/rugged/version.rb
   # source tarball doesn't include vendored libgit2 version, which is only
   # needed for test fixtures (resources): 
https://github.com/libgit2/rugged/issues/801
   mv -v ../libgit2-${_libgit2_pkgver}/* vendor/libgit2
@@ -42,7 +46,6 @@
   rake gem
 }
 
-# we're missing the fixtures from libgit2 to run the tests
 check(){
   cd "${pkgname}-${pkgver}"
   # ConfigTest#test_read_global_config_file fails, if no gitconfig is set for 
user...

Reply via email to