Date: Tuesday, December 3, 2019 @ 09:07:12
  Author: arojas
Revision: 370262

Revert sip5 changes, not ready yet

Modified:
  pyqt5/trunk/PKGBUILD

----------+
 PKGBUILD |    7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD    2019-12-03 07:41:57 UTC (rev 370261)
+++ PKGBUILD    2019-12-03 09:07:12 UTC (rev 370262)
@@ -7,11 +7,11 @@
 pkgbase=pyqt5
 pkgname=('pyqt5-common' 'python-pyqt5' 'python2-pyqt5')
 pkgver=5.13.2
-pkgrel=4
+pkgrel=3
 arch=('x86_64')
 url="https://riverbankcomputing.com/software/pyqt/intro";
 license=('GPL')
-makedepends=('sip5' 'python2-sip-pyqt5' 'sip' 'python-opengl' 'python2-opengl' 
'python2-enum34'
+makedepends=('python-sip-pyqt5' 'python2-sip-pyqt5' 'sip' 'python-opengl' 
'python2-opengl' 'python2-enum34'
              'python2-dbus' 'python-dbus' 'qt5-connectivity' 'qt5-multimedia' 
'qt5-tools' 'qt5-serialport' 'qt5-svg'
              'qt5-webkit' 'qt5-websockets' 'qt5-x11extras' 'qt5-networkauth' 
'qt5-xmlpatterns' 'qt5-remoteobjects')
 
source=("https://www.riverbankcomputing.com/static/Downloads/PyQt5/$pkgver/PyQt5-$pkgver.tar.gz";)
@@ -32,7 +32,6 @@
   cd "$srcdir"/PyQt5-$pkgver-py2
   python2 configure.py \
     --confirm-license \
-    --sip='/usr/bin/sip' \
     --no-sip-files \
     --qsci-api
   make
@@ -51,7 +50,7 @@
 
 package_python-pyqt5(){
   pkgdesc="A set of Python 3.x bindings for the Qt5 toolkit"
-  depends=('pyqt5-common')
+  depends=('python-sip-pyqt5' 'pyqt5-common')
   optdepends=('python-opengl: enable OpenGL 3D graphics in PyQt applications'
               'python-dbus: for python-dbus mainloop support'
               'qt5-multimedia: QtMultimedia, QtMultimediaWidgets'

Reply via email to