Date: Thursday, January 16, 2020 @ 03:53:09
  Author: svenstaro
Revision: 552729

archrelease: copy trunk to community-x86_64

Added:
  emscripten/repos/community-x86_64/PKGBUILD
    (from rev 552728, emscripten/trunk/PKGBUILD)
  emscripten/repos/community-x86_64/arch-template.patch
    (from rev 552728, emscripten/trunk/arch-template.patch)
  emscripten/repos/community-x86_64/emscripten.install
    (from rev 552728, emscripten/trunk/emscripten.install)
  emscripten/repos/community-x86_64/emscripten.sh
    (from rev 552728, emscripten/trunk/emscripten.sh)
  emscripten/repos/community-x86_64/libcxxabi-include-libunwind.patch
    (from rev 552728, emscripten/trunk/libcxxabi-include-libunwind.patch)
Deleted:
  emscripten/repos/community-x86_64/PKGBUILD
  emscripten/repos/community-x86_64/arch-template.patch
  emscripten/repos/community-x86_64/emscripten.install
  emscripten/repos/community-x86_64/emscripten.sh
  emscripten/repos/community-x86_64/libcxxabi-include-libunwind.patch

-----------------------------------+
 PKGBUILD                          |  158 ++++++++++++++++++------------------
 arch-template.patch               |   50 +++++------
 emscripten.install                |   26 ++---
 emscripten.sh                     |    4 
 libcxxabi-include-libunwind.patch |   24 ++---
 5 files changed, 131 insertions(+), 131 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD    2020-01-16 03:53:00 UTC (rev 552728)
+++ PKGBUILD    2020-01-16 03:53:09 UTC (rev 552729)
@@ -1,79 +0,0 @@
-# Maintainer: Sven-Hendrik Haase <svenst...@gmail.com>
-# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
-# Contributor: Stefan Husmann <stefan-husm...@t-online.de>
-# Contributor: Vlad Kolotvin <vlad.kolot...@gmail.com>
-
-pkgname=emscripten
-pkgver=1.39.5
-pkgrel=1
-pkgdesc="LLVM-based project that compiles C and C++ into highly-optimizable 
JavaScript for the web"
-arch=('x86_64')
-url="http://emscripten.org";
-license=('custom')
-depends=(nodejs python binaryen)
-makedepends=(cmake libxml2 git ninja)
-optdepends=('java-environment: for using clojure'
-            'ruby: for using websockify addon'
-            'cmake: for emcc --show-ports')
-install=emscripten.install
-# Get commit SHAs from here:
-# 
https://chromium.googlesource.com/emscripten-releases/+/refs/heads/master/DEPS
-source=(emscripten-$pkgver.tar.gz::"https://github.com/kripken/emscripten/archive/$pkgver.tar.gz";
-        
git+https://github.com/llvm/llvm-project.git#commit=411f1885b655ea622fe124a87a6eadfd988d7a5e
-        "emscripten.sh"
-        arch-template.patch
-        libcxxabi-include-libunwind.patch)
-sha512sums=('0a8d8e1b37b3787d96d899e73dbb55a408be8ce3d5be08c41c10f0ff1bf11659ec4188ffaf51066573a0e642981f31c686c89d7d7a54cddf0e35309f42741e1b'
-            'SKIP'
-            
'fbe9b95b8d18e7d0c6ec5fded6f11b72fbe4ddd0391e5704b281ba79c479f3563e82423b790ddf3f0554a23d659193ca898a81fe3db509f16c30c7188b790e4d'
-            
'04ffe0eac346d4accd54321aace952ccf3d6016243b98e3239de3fddc77c2c89ac4dfd66f65095c7f8a474e0e2b692bbbf3a150fde1dc410de920d5835f332a1'
-            
'3456c61bc8cc022f58cf2ae1ebda53057adc4f05fcddd71a6a69b172ef47ce41f1ded4cb49c49c71a68e8436d974458a06566d618a7dcbad9ded42fa5713386c')
-
-prepare() {
-  cd "$srcdir"/emscripten-$pkgver
-
-  patch -Np1 --no-backup-if-mismatch -i "$srcdir"/arch-template.patch
-
-  mkdir "$srcdir"/llvm-project/llvm/build
-}
-
-build() {
-  cd "$srcdir"/llvm-project/llvm/build
-
-  # Inspired from 
https://github.com/WebAssembly/waterfall/blob/58e343a47ea02cb6daf19eefbdf626b23c24980c/src/build.py#L790
-  cmake .. \
-    -GNinja \
-    -DPYTHON_EXECUTABLE=/usr/bin/python \
-    -DCMAKE_BUILD_TYPE=Release \
-    -DCMAKE_SKIP_RPATH=YES \
-    -DLLVM_TARGETS_TO_BUILD="X86;WebAssembly" \
-    -DLLVM_BUILD_RUNTIME=OFF \
-    -DLLVM_TOOL_LTO_BUILD=ON \
-    -DLLVM_INSTALL_TOOLCHAIN_ONLY=ON \
-    -DLLVM_INCLUDE_EXAMPLES=OFF \
-    -DLLVM_INCLUDE_TESTS=OFF \
-    -DLLVM_ENABLE_PROJECTS="lld;clang" \
-    -DCLANG_INCLUDE_TESTS=OFF
-  ninja
-}
-
-package() {
-  # Install LLVM stuff according to 
https://github.com/emscripten-core/emscripten/blob/incoming/docs/process.md
-  install -d "$pkgdir"/usr/lib
-  cp -r "$srcdir"/llvm-project/llvm/build/bin "$pkgdir"/usr/lib/emscripten-llvm
-
-  # Install emscripten
-  cd "$srcdir"/emscripten-$pkgver
-  install -d "$pkgdir"/usr/lib/emscripten
-  cp -rup em* cmake site src system third_party tools 
"$pkgdir"/usr/lib/emscripten
-
-  patch -Np1 --no-backup-if-mismatch -i 
"$srcdir"/libcxxabi-include-libunwind.patch -d "$pkgdir"
-
-  # Remove clutter
-  rm "$pkgdir"/usr/lib/emscripten/*.bat
-
-  install -d "$pkgdir"/usr/share/doc
-  ln -s /usr/lib/emscripten/site/source/docs "$pkgdir"/usr/share/doc/$pkgname
-  install -Dm755 "$srcdir"/emscripten.sh "$pkgdir"/etc/profile.d/emscripten.sh
-  install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-}

Copied: emscripten/repos/community-x86_64/PKGBUILD (from rev 552728, 
emscripten/trunk/PKGBUILD)
===================================================================
--- PKGBUILD                            (rev 0)
+++ PKGBUILD    2020-01-16 03:53:09 UTC (rev 552729)
@@ -0,0 +1,79 @@
+# Maintainer: Sven-Hendrik Haase <svenst...@gmail.com>
+# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: Stefan Husmann <stefan-husm...@t-online.de>
+# Contributor: Vlad Kolotvin <vlad.kolot...@gmail.com>
+
+pkgname=emscripten
+pkgver=1.39.6
+pkgrel=1
+pkgdesc="LLVM-based project that compiles C and C++ into highly-optimizable 
JavaScript for the web"
+arch=('x86_64')
+url="http://emscripten.org";
+license=('custom')
+depends=(nodejs python binaryen)
+makedepends=(cmake libxml2 git ninja)
+optdepends=('java-environment: for using clojure'
+            'ruby: for using websockify addon'
+            'cmake: for emcc --show-ports')
+install=emscripten.install
+# Get commit SHAs from here:
+# 
https://chromium.googlesource.com/emscripten-releases/+/refs/heads/master/DEPS
+source=(emscripten-$pkgver.tar.gz::"https://github.com/kripken/emscripten/archive/$pkgver.tar.gz";
+        
git+https://github.com/llvm/llvm-project.git#commit=411f1885b655ea622fe124a87a6eadfd988d7a5e
+        "emscripten.sh"
+        arch-template.patch
+        libcxxabi-include-libunwind.patch)
+sha512sums=('fce81eca3a2e6ae9b2e6f298476b0df81ce905c7224514acd1729eea11eb110ea65ebf73bb5fc37b108b1164bfc35d41a203298b97729009cff50604249e7857'
+            'SKIP'
+            
'fbe9b95b8d18e7d0c6ec5fded6f11b72fbe4ddd0391e5704b281ba79c479f3563e82423b790ddf3f0554a23d659193ca898a81fe3db509f16c30c7188b790e4d'
+            
'04ffe0eac346d4accd54321aace952ccf3d6016243b98e3239de3fddc77c2c89ac4dfd66f65095c7f8a474e0e2b692bbbf3a150fde1dc410de920d5835f332a1'
+            
'3456c61bc8cc022f58cf2ae1ebda53057adc4f05fcddd71a6a69b172ef47ce41f1ded4cb49c49c71a68e8436d974458a06566d618a7dcbad9ded42fa5713386c')
+
+prepare() {
+  cd "$srcdir"/emscripten-$pkgver
+
+  patch -Np1 --no-backup-if-mismatch -i "$srcdir"/arch-template.patch
+
+  mkdir "$srcdir"/llvm-project/llvm/build
+}
+
+build() {
+  cd "$srcdir"/llvm-project/llvm/build
+
+  # Inspired from 
https://github.com/WebAssembly/waterfall/blob/58e343a47ea02cb6daf19eefbdf626b23c24980c/src/build.py#L790
+  cmake .. \
+    -GNinja \
+    -DPYTHON_EXECUTABLE=/usr/bin/python \
+    -DCMAKE_BUILD_TYPE=Release \
+    -DCMAKE_SKIP_RPATH=YES \
+    -DLLVM_TARGETS_TO_BUILD="X86;WebAssembly" \
+    -DLLVM_BUILD_RUNTIME=OFF \
+    -DLLVM_TOOL_LTO_BUILD=ON \
+    -DLLVM_INSTALL_TOOLCHAIN_ONLY=ON \
+    -DLLVM_INCLUDE_EXAMPLES=OFF \
+    -DLLVM_INCLUDE_TESTS=OFF \
+    -DLLVM_ENABLE_PROJECTS="lld;clang" \
+    -DCLANG_INCLUDE_TESTS=OFF
+  ninja
+}
+
+package() {
+  # Install LLVM stuff according to 
https://github.com/emscripten-core/emscripten/blob/incoming/docs/process.md
+  install -d "$pkgdir"/usr/lib
+  cp -r "$srcdir"/llvm-project/llvm/build/bin "$pkgdir"/usr/lib/emscripten-llvm
+
+  # Install emscripten
+  cd "$srcdir"/emscripten-$pkgver
+  install -d "$pkgdir"/usr/lib/emscripten
+  cp -rup em* cmake site src system third_party tools 
"$pkgdir"/usr/lib/emscripten
+
+  patch -Np1 --no-backup-if-mismatch -i 
"$srcdir"/libcxxabi-include-libunwind.patch -d "$pkgdir"
+
+  # Remove clutter
+  rm "$pkgdir"/usr/lib/emscripten/*.bat
+
+  install -d "$pkgdir"/usr/share/doc
+  ln -s /usr/lib/emscripten/site/source/docs "$pkgdir"/usr/share/doc/$pkgname
+  install -Dm755 "$srcdir"/emscripten.sh "$pkgdir"/etc/profile.d/emscripten.sh
+  install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}

Deleted: arch-template.patch
===================================================================
--- arch-template.patch 2020-01-16 03:53:00 UTC (rev 552728)
+++ arch-template.patch 2020-01-16 03:53:09 UTC (rev 552729)
@@ -1,25 +0,0 @@
-diff --git a/tools/settings_template.py b/tools/settings_template.py
-index f1ca646ea..3e85c7ab1 100644
---- a/tools/settings_template.py
-+++ b/tools/settings_template.py
-@@ -12,9 +12,9 @@ import os
- 
- # This is used by external projects in order to find emscripten.  It is not 
used
- # by emscripten itself.
--EMSCRIPTEN_ROOT = os.path.expanduser(os.getenv('EMSCRIPTEN', '{{{ 
EMSCRIPTEN_ROOT }}}')) # directory
-+EMSCRIPTEN_ROOT = "/usr/lib/emscripten"
- 
--LLVM_ROOT = os.path.expanduser(os.getenv('LLVM', '{{{ LLVM_ROOT }}}')) # 
directory
-+LLVM_ROOT = "/usr/lib/emscripten-llvm"
- BINARYEN_ROOT = os.path.expanduser(os.getenv('BINARYEN', '')) # directory
- 
- # Add this if you have manually built the JS optimizer executable (in
-@@ -43,7 +43,7 @@ JAVA = 'java' # executable
- # All JS engines to use when running the automatic tests. Not all the engines 
in
- # this list must exist (if they don't, they will be skipped in the test 
runner).
- #
--# JS_ENGINES = [NODE_JS] # add V8_ENGINE or SPIDERMONKEY_ENGINE if you have 
them installed too.
-+JS_ENGINES = [NODE_JS] # add V8_ENGINE or SPIDERMONKEY_ENGINE if you have 
them installed too.
- #
- # WASMER = os.path.expanduser(os.path.join('~', '.wasmer', 'bin', 'wasmer'))
- # WASMTIME = os.path.expanduser(os.path.join('~', 'wasmtime'))

Copied: emscripten/repos/community-x86_64/arch-template.patch (from rev 552728, 
emscripten/trunk/arch-template.patch)
===================================================================
--- arch-template.patch                         (rev 0)
+++ arch-template.patch 2020-01-16 03:53:09 UTC (rev 552729)
@@ -0,0 +1,25 @@
+diff --git a/tools/settings_template.py b/tools/settings_template.py
+index f1ca646ea..3e85c7ab1 100644
+--- a/tools/settings_template.py
++++ b/tools/settings_template.py
+@@ -12,9 +12,9 @@ import os
+ 
+ # This is used by external projects in order to find emscripten.  It is not 
used
+ # by emscripten itself.
+-EMSCRIPTEN_ROOT = os.path.expanduser(os.getenv('EMSCRIPTEN', '{{{ 
EMSCRIPTEN_ROOT }}}')) # directory
++EMSCRIPTEN_ROOT = "/usr/lib/emscripten"
+ 
+-LLVM_ROOT = os.path.expanduser(os.getenv('LLVM', '{{{ LLVM_ROOT }}}')) # 
directory
++LLVM_ROOT = "/usr/lib/emscripten-llvm"
+ BINARYEN_ROOT = os.path.expanduser(os.getenv('BINARYEN', '')) # directory
+ 
+ # Add this if you have manually built the JS optimizer executable (in
+@@ -43,7 +43,7 @@ JAVA = 'java' # executable
+ # All JS engines to use when running the automatic tests. Not all the engines 
in
+ # this list must exist (if they don't, they will be skipped in the test 
runner).
+ #
+-# JS_ENGINES = [NODE_JS] # add V8_ENGINE or SPIDERMONKEY_ENGINE if you have 
them installed too.
++JS_ENGINES = [NODE_JS] # add V8_ENGINE or SPIDERMONKEY_ENGINE if you have 
them installed too.
+ #
+ # WASMER = os.path.expanduser(os.path.join('~', '.wasmer', 'bin', 'wasmer'))
+ # WASMTIME = os.path.expanduser(os.path.join('~', 'wasmtime'))

Deleted: emscripten.install
===================================================================
--- emscripten.install  2020-01-16 03:53:00 UTC (rev 552728)
+++ emscripten.install  2020-01-16 03:53:09 UTC (rev 552729)
@@ -1,13 +0,0 @@
-
-post_install() {
-  echo "You need to login again or 'source /etc/profile.d/emscripten.sh' in 
your"
-  echo "already running shells to be able to use emscripten."
-}
-
-post_upgrade() {
-  echo "You may need to manually clear your emscripten cache as clang may not 
link"
-  echo "the new library versions with cached data properly. Use this command:"
-  echo "$ emcc --clear-cache"
-  echo "You may also need to delete ~/.emscripten if emscripten complains 
about old paths"
-  echo "or executables not found."
-}

Copied: emscripten/repos/community-x86_64/emscripten.install (from rev 552728, 
emscripten/trunk/emscripten.install)
===================================================================
--- emscripten.install                          (rev 0)
+++ emscripten.install  2020-01-16 03:53:09 UTC (rev 552729)
@@ -0,0 +1,13 @@
+
+post_install() {
+  echo "You need to login again or 'source /etc/profile.d/emscripten.sh' in 
your"
+  echo "already running shells to be able to use emscripten."
+}
+
+post_upgrade() {
+  echo "You may need to manually clear your emscripten cache as clang may not 
link"
+  echo "the new library versions with cached data properly. Use this command:"
+  echo "$ emcc --clear-cache"
+  echo "You may also need to delete ~/.emscripten if emscripten complains 
about old paths"
+  echo "or executables not found."
+}

Deleted: emscripten.sh
===================================================================
--- emscripten.sh       2020-01-16 03:53:00 UTC (rev 552728)
+++ emscripten.sh       2020-01-16 03:53:09 UTC (rev 552729)
@@ -1,2 +0,0 @@
-#!/bin/sh
-export PATH=$PATH:/usr/lib/emscripten

Copied: emscripten/repos/community-x86_64/emscripten.sh (from rev 552728, 
emscripten/trunk/emscripten.sh)
===================================================================
--- emscripten.sh                               (rev 0)
+++ emscripten.sh       2020-01-16 03:53:09 UTC (rev 552729)
@@ -0,0 +1,2 @@
+#!/bin/sh
+export PATH=$PATH:/usr/lib/emscripten

Deleted: libcxxabi-include-libunwind.patch
===================================================================
--- libcxxabi-include-libunwind.patch   2020-01-16 03:53:00 UTC (rev 552728)
+++ libcxxabi-include-libunwind.patch   2020-01-16 03:53:09 UTC (rev 552729)
@@ -1,12 +0,0 @@
---- a/usr/lib/emscripten/tools/system_libs.py
-+++ b/usr/lib/emscripten/tools/system_libs.py
-@@ -758,6 +758,9 @@ class libcxxabi(CXXLibrary, NoExceptLibrary, MTLibrary):
-   name = 'libc++abi'
-   depends = ['libc']
-   cflags = ['-std=c++11', '-Oz', '-D_LIBCPP_DISABLE_VISIBILITY_ANNOTATIONS']
-+  includes = [
-+    ['system', 'lib', 'libunwind', 'include'],
-+  ]
- 
-   def get_cflags(self):
-     cflags = super(libcxxabi, self).get_cflags()

Copied: emscripten/repos/community-x86_64/libcxxabi-include-libunwind.patch 
(from rev 552728, emscripten/trunk/libcxxabi-include-libunwind.patch)
===================================================================
--- libcxxabi-include-libunwind.patch                           (rev 0)
+++ libcxxabi-include-libunwind.patch   2020-01-16 03:53:09 UTC (rev 552729)
@@ -0,0 +1,12 @@
+--- a/usr/lib/emscripten/tools/system_libs.py
++++ b/usr/lib/emscripten/tools/system_libs.py
+@@ -758,6 +758,9 @@ class libcxxabi(CXXLibrary, NoExceptLibrary, MTLibrary):
+   name = 'libc++abi'
+   depends = ['libc']
+   cflags = ['-std=c++11', '-Oz', '-D_LIBCPP_DISABLE_VISIBILITY_ANNOTATIONS']
++  includes = [
++    ['system', 'lib', 'libunwind', 'include'],
++  ]
+ 
+   def get_cflags(self):
+     cflags = super(libcxxabi, self).get_cflags()

Reply via email to