First let me explain I have search through the forums, StackExchange site
(SuperUser & Linux Unix StackExhange) and read the problems with similar title,
90% of which were USB install and related to failure to have the proper iso name
(e.g ARCH_201603) as the image name, the other 10% were related to
/dev/disk/by-label not being created and suggest the creation of the directory
and symlink of the install device (e.g. /dev/sr0 to
/dev/disk/by-label/ARCH_201603) and exiting the maintenance shell to have the
install pickup and continue. Neither of these are a solution.

  I have one Supermicro server (similar but slightly older) where the install
went without issue (H8QM8-2 w/4 Opteron 8360SE). This server is the
H8DME-2-LS006 Rev 1.10 w/2 Opteron 8382 processors. (specs:

  Initially, the boot would hang during pci activation with the line

    pci 000:00:1a.0: [1a:1e:1100] type -- class 0x060000

  I reset the bios to the failsafe defaults, still no joy.

  The Hardware Detection Tool showed a 3Leaf Systems, Inc.|unknown device at
that address, the details of which were:

    Vendor   : 3Leaf Systems, Inc.
    Product  : unknown
    Class    : Host bridge
    Location : 00:1a.0
    PCI ID   : 1a1e:1100[0000:0000]
    Latency  : 0
    Module   : unknown

  Looking though all the bios options, trying one at a time, I found an option
for something related to AQUA (? This board an AQUA were apparently the
brainchild of 3Leaf, Inc. now out of business which allowed you to link 32
Opteron processors into a single server)

  So disabling AQUA completely in the bios allowed the box to boot normally all
the way though:

    :: running hook [archiso_pxe_nfs]
    :: Mounting '/dev/disk/by-label/ARCH_201603' to '/run/archiso/bootmnt'
    Waiting 30 seconds for devices....

  then the error and I'm dropped to the maintenance shell (e.g. [rootfs /]# ).
I've tried the solutions shown at the beginning but I still can't proceed with
the remainder of the install. When I create the /dev/disk/by-label directory,
create the symlink, and exit the maintenance shell, I get the following error:

    Buffer I/O error on dev sr0 logical block 0, async page read
    sr 6:0:1:0 [sr0] tag#0 UNKNOWN(0x2003) Result:hostbyte-0x00 driverbyte=0x08
    sr 6:0:1:0 [sr0] tag#0 Sense Key : 0x4 [current]
    sr 6:0:1:0 [sr0] tag#0 ASC=0x8 ASCQ=0x3
    sr 6:0:1:0 [sr0] tag#0 CDB: opcode: 0x28 28 00 00 00 00 00 00 00 02 00
    blk_update_request: I/O error, dev sr0, sector 0
    isofs_fill_super: bread failed, dev=sr0, iso_blknum=16, block=16

  So I need help from the smart folks here. I'm not entirely sure what this
error is telling me other than there is some UNKNOWN result that prevents the
archiso mount. With this AQUA setting completely disabled in the bios, I don't
know if this error is related to that setting, but I suspect it is. What could I
try to get past this error? Is there some kernel parameter I coud try to pass at
boot that might help? Has anyone else seen this or found another solution?

  Thanks for any advise you can give..

David C. Rankin, J.D.,P.E.

Reply via email to