Arch Linux Security Advisory ASA-201609-15
==========================================

Severity: Low
Date    : 2016-09-17
CVE-ID  : CVE-2016-4425
Package : jansson
Type    : denial of service
Remote  : Yes
Link    : https://wiki.archlinux.org/index.php/CVE

Summary
=======

The package jansson before version 2.8-1 is vulnerable to denial of service.

Resolution
==========

Upgrade to 2.8-1.

# pacman -Syu "jansson>=2.8-1"

The problem has been fixed upstream in version 2.8.

Workaround
==========

None.

Description
===========

A stack-exhaustion vulnerability has been found in jansson, causing a
crash while parsing a crafted JSON document.

Impact
======

A remote attacker might cause a crash by submitting a specially crafted
JSON file to an application using jansson, leading to denial of service.

References
==========

http://marc.info/?l=oss-security&m=146219323703639&w=2
https://github.com/akheron/jansson/issues/282
https://access.redhat.com/security/cve/CVE-2016-4425

Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to