Arch Linux Security Advisory ASA-201610-8
=========================================

Severity: Medium
Date    : 2016-10-12
CVE-ID  : CVE-2016-7420
Package : crypto++
Type    : information disclosure
Remote  : No
Link    : https://wiki.archlinux.org/index.php/CVE

Summary
=======

The package crypto++ before version 5.6.5-1 is vulnerable to
information disclosure.

Resolution
==========

Upgrade to 5.6.5-1.

# pacman -Syu "crypto++>=5.6.5-1"

The problem has been fixed upstream in version 5.6.5.

Workaround
==========

None.

Description
===========

Crypto++ (aka cryptopp) through 5.6.4 does not document the requirement
for a compile-time NDEBUG definition disabling the many assert calls
that are unintended in production use, which might allow context-
dependent attackers to obtain sensitive information by leveraging access
to process memory after an assertion failure, as demonstrated by reading
a core dump.

Impact
======

An attacker can provide input to programs using crypto++ that may cause
a crash and lead to the disclosure of sensitive information in a core
dump.

References
==========

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-7420
https://bugs.archlinux.org/task/51331
https://github.com/weidai11/cryptopp/issues/277
http://www.openwall.com/lists/oss-security/2016/09/15/12

Attachment: signature.asc
Description: PGP signature

Reply via email to