We are currently looking at transitioning away from repositories in 
ArchivesSpace, and using classifications in a similar manner to what you 
described. In testing this, however, we are seeing similar delays in loading 
times in our 1.5.4 installation.

I recently reported this as a bug in JIRA 
(, but wondered 
if you were ever able to get this addressed or resolved?


Cory Nimer
University Archivist
Brigham Young University

[] On Behalf Of
Sent: Monday, July 17, 2017 7:27 AM
Subject: [Archivesspace_Users_Group] Problem with Classifications: 
searching/adding to records

We have been having a problem with Classifications for quite some time - we are 
currently in version 1.5.2, but I think the issue actually predates our move to 
1.5.2 and it's just finally gotten exasperating. And we did some testing on 
2.1.0-RC1, and it persists.

In our workflow, every Accession and Resource record is assigned a 
Classification. When adding a Classification to the Accession/Resource record, 
AS takes a long time to search/find Classifications, particularly the one with 
(by far) the most records associated with it (about 3300). Saving is also very 
slow (slow enough that the browser can tell us as the percentage uploaded 
increases). We've monitored the system while going through these processes, and 
Java is working overtime during the search process.

Has anyone else seen this? And/or have ideas as to how we can fix it?


Carrie Daniels
University Archivist and
Director, Archives and Special Collections
University of Louisville

Archivesspace_Users_Group mailing list

Reply via email to