On Fri, Apr 6, 2018 at 9:22 AM, Nicolas Chauvet <kwiz...@gmail.com> wrote:
> Hi there,
> FYI I've backported the tegra/nouveau support that has landed in mesa
> master recently on top of mesa-18.0
> Here is a koji scratch build:
> https://koji.fedoraproject.org/koji/taskinfo?taskID=26171305
> I'm testing it only on a jetson-tk1 (armv7hl) for now, using a 4.16.0 kernel.
> But in this case, I have the following message (that freeze the system).
> [ 1140.014947] nouveau 57000000.gpu: fifo: SCHED_ERROR 20 []
> Because of that, I need to boot with rd.driver.blacklist=nouveau
> modprobe.blacklist=nouveau from cmdline.
> I'm trying to have it reported upstream.

I reported this upstream around rc4 but I've not heard anything, I've
been away and just booted the TK1 up again yesterday and I was seeing
the same and have updated the details.

> Even with nouveau disabled, and using the mesa with tegra backport,
> I'm able to run a wayland session on tegra. (very slowly). this was
> not the case before the mesa tegra backport as it fallback on Xorg.

I've been running wayland on the TK1 for a number of cycles
accelerated, this has worked for some time, the patches you reference
improve a number of things and take it up a notch.

> I don't think there is any improvement on SOC older than tegra k1. I
> haven't tried yet.

Nope, because SoCs older than the TK1 don't use nouveau.

> I hope you can enjoy.
> PS: I think this is a little too much for backport the whole tegra
> support to the normal fedora package. But if it's something to
> consider, I can submit a PR on mesa...

It's too large IMO, but then mesa tends to back port new versions
regularly so we'll see it soon enouygh.

arm mailing list -- arm@lists.fedoraproject.org
To unsubscribe send an email to arm-le...@lists.fedoraproject.org

Reply via email to