On Mon, Apr 9, 2018 at 10:04 PM, Pierre-Francois RENARD
<pfren...@gmail.com> wrote:
>
> Ok, I worked a little on this issue and I found something.
>
> module spidev is not loaded, so it tried to load it with modprobe spidev.
> it worked but nothing was created into /dev
>
> I also ran  dtc -Ifs /proc/device-tree
> and found
>
> spi@7e204000 {
>                         compatible = "brcm,bcm2835-spi";
>                         clocks = <0x7 0x14>;
>                         status = "disabled";
>                         #address-cells = <0x1>;
>                         interrupts = <0x2 0x16>;
>                         #size-cells = <0x0>;
>                         reg = <0x7e204000 0x1000>;
>                 };
>
> spi@7e215080 {
>                         compatible = "brcm,bcm2835-aux-spi";
>                         clocks = <0xf 0x1>;
>                         status = "disabled";
>                         #address-cells = <0x1>;
>                         interrupts = <0x1 0x1d>;
>                         #size-cells = <0x0>;
>                         reg = <0x7e215080 0x40>;
>                 };
>
> spi@7e2150c0 {
>                         compatible = "brcm,bcm2835-aux-spi";
>                         clocks = <0xf 0x2>;
>                         status = "disabled";
>                         #address-cells = <0x1>;
>                         interrupts = <0x1 0x1d>;
>                         #size-cells = <0x0>;
>                         reg = <0x7e2150c0 0x40>;
>                 };
>
> but status of these trees is "disabled" ...
> how can I enable them, that will probably creat the devices into /dev :)

I'm hoping to have a solution to that shortly, it's not working just
yet which is why I'm yet to respond with details
_______________________________________________
arm mailing list -- arm@lists.fedoraproject.org
To unsubscribe send an email to arm-le...@lists.fedoraproject.org

Reply via email to