Hi Oliver,

  I guess, I have found the origin of the issue:

  I'm still in my home directory (/home/yuriy) after I did "git clone" and I 
did not move to /home/yuriy/arts.
  It means that mkdir -p build makes the directory /home/yuriy/build instead of 
  Basically, to fix this, user should only run cd arts before making the 
directory /build

  Probably, the error below also linked to some folder mismatch.
Hopefully, it is not the end of the world (hopefully I could download all pdfs 
from the website)



! LaTeX Error: File `paralist.sty' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)

Enter file name:
! Emergency stop.
<read *>

l.11 \setlength
               \parindent{0pt} % Removes all indentation from paragraphs - c...

Here is how much of TeX's memory you used:
 4999 strings out of 494923
 81780 string characters out of 6180742
 244377 words of memory out of 5000000
 8308 multiletter control sequences out of 15000+600000
 4709 words of font info for 16 fonts, out of 8000000 for 9000
 14 hyphenation exceptions out of 8191
 41i,1n,51p,8885b,137s stack positions out of 5000i,500n,10000p,200000b,15000s
!  ==> Fatal error occurred, no output PDF file produced!
 recipe for target 
'doc/classroom_excercises_solutions/exe2_rtcalc/exe2_solution.pdf' failed
make[2]: *** [doc/classroom_excercises_solutions/exe2_rtcalc/exe2_solution.pdf] 
Error 1
CMakeFiles/Makefile2:2106: recipe for target 
make[1]: *** 
 Error 2
Makefile:140: recipe for target 'all' failed
make: *** [all] Error 2

PS1: Just in case, This is the list of libraries required to compile ARTS in 
Ubuntu 18.04. Hopefully it could save some time for other users.

   libblas-dev, zlib1g, cmake, libnetcdf-dev, libnetcdff-dev, texlive, doxygen

PS2: Could you include my address into the list arts-users mailing list to get 
the access to arts_users.mi Archives? I tried few times but my email/password 
is still inactive.

Thank you,

On 9/19/2019 12:11 AM, Oliver Lemke wrote:

Hi Yuriy,

On 19 Sep 2019, at 00:36, Goncharenko,Yuriy 
<yuriy.gonchare...@colostate.edu><mailto:yuriy.gonchare...@colostate.edu> wrote:

Hi Oliver,

  it looks like the module path is set wrong. Basically, the source directory 
is set
as /home/yuriy/  instead of /home/yuriy/arts/

Great that it works now.

I believe it happened because I use
cmake ..
(as it was suggested at the ARTS website) instead of
cmake /home/yuriy/arts/

(as it was suggested in CMakeLists.txt)

There must be something else going on because running 'cmake ..' after cd'ing 
into the 'build' directory worked on every configuration we have encountered in 
testing so far.

One more question concerning your setup (so I can reproduce it for testing): 
Are you using Ubuntu as a standalone Virtual Machine (vmware, virtualbox) or 
did you install the Ubuntu App from the Microsoft Store?

Thanks for pointing out this issue.


arts_users.mi mailing list

Reply via email to