Thank you very much for the support.

After installing the master branch and running the 'make check' command, I got 
a weird error message that read:

[ 10%] Building CXX object 
In file included from /opt/arts-master/src/matpackI.h:102,
                 from /opt/arts-master/src/methods.h:32,
                 from /opt/arts-master/src/global_data.h:31,
/opt/arts-master/src/matpack_concepts.h:4:10: fatal error: concepts: No such 
file or directory
    4 | #include <concepts>
      |          ^~~~~~~~~~
compilation terminated.

I'm sure this file exists and my machine should meet the requirements as well.
Reinstalling ARTS 2.4 worked fine before.

Is this a known issue?

Best regards

Von: Lemke, Oliver <>
Gesendet: Mittwoch, 14. September 2022 08:54:20
An: Krochin, Witali (IAP)
Cc: Buehler, Stefan; Richard Larsson; ARTS Users List
Betreff: Re: [arts-users] Temperature Retrievals of Oxygen emission lines with 
Zeeman effect and line mixing

Hi Witali,

The error you're seeing indicates that you're using an older ARTS version. To 
read the newest version of the arts-cat-data, you also need to compile the 
latest ARTS development version from the master branch at .


> On 13 Sep 2022, at 17:18, wrote:
> Thank you for the quick reply and comments on the updated papers.
> We will definitely add Mr. Larsson to the list of co-authors when the 
> research using this dataset is published.
> Unfortunately, I am already having problems reading the dataset.
> I have downloaded the file "O2-66.xml" from 
> but I cannot read the file with any reading function that are known to me.
> For example, the following line:
> "ReadXML(abs_lines, "O2-66.xml")"
> Generates the following error message:
> "Species "" is not a valid species."
> I've tried several other read functions, but I have a feeling I'm missing 
> something.
> Best regards
> Witali

Reply via email to