I mentioned this last week - when my system was downloading a TLDlist,
as soon as it started downloading, it stopped responding to anything,
and the system would not detect any available workers.

I noticed today that the same exact thing is happening when it tries to
download a new version of ASSP:

Oct-17-16 16:42:27 [Worker_10000] Info: next assp version check download
in 15 hours 36 mins
Oct-17-16 16:42:53 [Worker_10000] Info: notification message queued to
sent to r...@netbound.com
Oct-17-16 16:42:27 [Worker_10000] Info: new assp version 2.5.4(16291) is
available for download at
http://assp.cvs.sourceforge.net/viewvc/*checkout*/assp/assp2/assp.pl.gz
Oct-17-16 16:42:53 [Worker_10000] Info: autoupdate: performing
assp.pl.gz download to D:/ASSP/download/assp.pl.gz
Oct-17-16 16:42:53 [Worker_10000] Downloading assp.pl.gz via direct HTTP
connection
Oct-17-16 16:43:06 [Main_Thread] Info: unable to detect any running
worker for a new connection - wait (max 30 seconds)
Oct-17-16 16:43:06 [Main_Thread] Info: unable to detect any running
worker for a new connection - wait (max 30 seconds)
Oct-17-16 16:43:06 [Main_Thread] Info: unable to detect any running
worker for a new connection - wait (max 30 seconds)

This goes on for a minute and a half, and then the same thing happens
when it starts to decompress it:

Oct-17-16 16:44:35 [Main_Thread] Info: unable to detect any running
worker for a new connection - wait (max 30 seconds)
Oct-17-16 16:44:35 [Main_Thread] Info: unable to detect any running
worker for a new connection - wait (max 30 seconds)
Oct-17-16 16:44:35 [Worker_10000] Assp.pl.gz download completed
Oct-17-16 16:44:35 [Worker_10000] Info: next assp.pl.gz download in 14
hours 45 mins
Oct-17-16 16:44:35 [Worker_10000] Info: autoupdate: new assp.pl.gz
downloaded to D:/ASSP/download/assp.pl.gz
Oct-17-16 16:44:35 [Worker_10000] Decompressing file
D:/ASSP/download/assp.pl.gz to D:/ASSP/download/assp.pl
Oct-17-16 16:44:35 [Main_Thread] Info: unable to detect any running
worker for a new connection - wait (max 30 seconds)
Oct-17-16 16:44:35 [Main_Thread] Info: unable to detect any running
worker for a new connection - wait (max 30 seconds)

It finally gives up and shuts down:

Oct-17-16 16:45:09 [Main_Thread] Info: unable to detect any running
worker for a new connection - wait (max 30 seconds)
Oct-17-16 16:45:10 [Main_Thread] Info: unable to detect any running
worker for a new connection - wait (max 30 seconds)
Oct-17-16 16:45:10 [Main_Thread] Info: ConnectionTransferTimeOut (30
seconds) is now reached
Oct-17-16 16:45:10 [Main_Thread] Warning: Main_Thread is unable to
transfer connection to any worker - try again!
Oct-17-16 16:45:16 [Main_Thread] Info: notification message queued to
sent to ad...@domain.com
Oct-17-16 16:45:10 [Main_Thread] Error: Main_Thread is unable to
transfer connection to any worker within 120 seconds - restart ASSP!
Oct-17-16 16:45:16 [Main_Thread] Initializing shutdown sequence
Oct-17-16 16:45:17 [Shutdown] Info: removing all SMTP and Proxy listeners
Oct-17-16 16:45:19 [Shutdown] Tell Worker 2 - QUIT
Oct-17-16 16:45:19 [Shutdown] Tell Worker 4 - QUIT
Oct-17-16 16:45:19 [Shutdown] Tell Worker 1 - QUIT
Oct-17-16 16:45:19 [Shutdown] Tell Worker 3 - QUIT
Oct-17-16 16:45:19 [Shutdown] Tell Worker 5 - QUIT
Oct-17-16 16:45:19 [Shutdown] Waiting for all SMTP-Workers to be finished
Oct-17-16 16:45:21 [Worker_5] Worker_5 wakes up
Oct-17-16 16:46:09 [Shutdown] Error: at least one of the SMTP workers
has not finished work within 50 seconds
Oct-17-16 16:46:11 [Shutdown] Closing all databases

The same thing happens after it reorders DNS servers. It seems any time
my ASSP does anything that has to do with maintenance, all the workers
shut down and stop responding. Any idea what might be causing this?



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most 
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Assp-test mailing list
Assp-test@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/assp-test

Reply via email to