Hi John,

You need to capture the output of the perl module installer and find out why 
all those modules are failing to install. Fix that. Alternatively, try 
installing each module manually and see the errors.

I’m running Ubuntu 16 and the installer would install most of those if the 
system was set up right.

All the best,
Colin.

From: John Wolf <jwo...@gmail.com>
Sent: 13 April 2018 18:51
To: ASSP development mailing list <Assp-test@lists.sourceforge.net>
Subject: [Assp-test] RebuildSDB not running

Hello All,
A month or so ago I created a new virtual machine in Virtual box.  It is a 
virtual Ubuntu 16.04 server currently running ASSP version 2.6.1  *Fortress*  
build 17355 .  I don't know if I missed something during the install, it seems 
to be working ok except the rebuildsdb process aborts out.  The log shows the 
following:
Server Name:

sfilter



ASSP host UUID:

d96937e9-2ed4-11e8-8f8d-e4fd4c4d0c10



Server OS:

linux



Server IP:

127.0.1.1



used DNS Servers:

192.168.xxx.3 192.168.xxx.254

Local DNS Servers<http://192.168.50.4:55555/#UseLocalDNS> in use



defined DNS Servers:

192.168.xxxx.3 192.168.xxx.254



DNS Servers query time:

min: 0.000 , avg: 0.031 , max: 0.226



Perl Version:

5.022001

Perl.org<http://www.perl.org/get.html>

assp-process-memory:

current: 1407 MB

min: 1075 MB

max: 1407 MB

Spamdb version:

used:

2_14315_UAX#29_UAX#15_WordStem2.02

required:

2_14315_UAX#15

HMMdb version:

used:

n/a

required:

2_14315_UAX#15

code integrity signature:

expected:

D052878A93FA57BC3AAF9774BF1407E1845BD98E

current:

D052878A93FA57BC3AAF9774BF1407E1845BD98E

ASSP Version:

2.6.1(17355)

show current local change log

show last available change 
log<http://downloads.sourceforge.net/project/assp/ASSP%20V2%20multithreading/changelog.txt>


release<http://sourceforge.net/project/showfiles.php?group_id=69172>

beta<http://sourceforge.net/p/assp/svn/HEAD/tree/assp2/trunk/>





 Apr-13-18 11:58:25 [Worker_10001] Start rebuildAddCorrections

 Apr-13-18 11:58:25 [Worker_10001] Error: Can't locate object method "priority" 
via package "threads" at sub ASSP::Priority::new line 11.

 Apr-13-18 11:58:25 [Worker_10001] Info: RebuildSpamdb Scheduler stopped

 Apr-13-18 11:58:25 [Worker_10001] Info: starting RebuildSpamdb Scheduler with 
'00 01 * * *' - next RebuildSpamdb is scheduled for Apr-14-18 01:00:00

 Apr-13-18 11:58:28 m1-35100-03802 [Worker_2] 66.220.155.145 
<notification+pvv13...@facebookmail.com<mailto:notification%2bpvv13...@facebookmail.com>>
 to: adw...@wselectronics.com<mailto:adw...@wselectronics.com> info: 
PB-IP-Score for '66.220.155.0' is 0, added 10 in this session

 Apr-13-18 11:58:30 [Worker_10001] Start rebuildAddCorrections

 Apr-13-18 11:58:30 [Worker_10001] Error: Can't locate object method "priority" 
via package "threads" at sub ASSP::Priority::new line 11.

 Apr-13-18 11:58:30 [Worker_10001] Info: RebuildSpamdb Scheduler stopped

 Apr-13-18 11:58:30 [Worker_10001] Info: starting RebuildSpamdb Scheduler with 
'00 01 * * *' - next RebuildSpamdb is scheduled for Apr-14-18 01:00:00

 Apr-13-18 11:58:35 [Worker_10001] Start rebuildAddCorrections

 Apr-13-18 11:58:35 [Worker_10001] Error: Can't locate object method "priority" 
via package "threads" at sub ASSP::Priority::new line 11.

 Apr-13-18 11:58:35 [Worker_10001] Info: RebuildSpamdb Scheduler stopped

 Apr-13-18 11:58:35 [Worker_10001] Info: starting RebuildSpamdb Scheduler with 
'00 01 * * *' - next RebuildSpamdb is scheduled for Apr-14-18 01:00:00

 Apr-13-18 11:58:40 [Worker_10001] Start rebuildAddCorrections

 Apr-13-18 11:58:40 [Worker_10001] Error: Can't locate object method "priority" 
via package "threads" at sub ASSP::Priority::new line 11.

 Apr-13-18 11:58:40 [Worker_10001] Info: RebuildSpamdb Scheduler stopped

 Apr-13-18 11:58:40 [Worker_10001] Info: starting RebuildSpamdb Scheduler with 
'00 01 * * *' - next RebuildSpamdb is scheduled for Apr-14-18 01:00:00

 Apr-13-18 11:58:45 [Worker_10001] Start rebuildAddCorrections

 Apr-13-18 11:58:45 [Worker_10001] Error: Can't locate object method "priority" 
via package "threads" at sub ASSP::Priority::new line 11.

 Apr-13-18 11:58:45 [Worker_10001] Info: RebuildSpamdb Scheduler stopped

 Apr-13-18 11:58:45 [Worker_10001] Info: starting RebuildSpamdb Scheduler with 
'00 01 * * *' - next RebuildSpamdb is scheduled for Apr-14-18 01:00:00

 Apr-13-18 11:58:50 [Worker_10001] Start rebuildAddCorrections

 Apr-13-18 11:58:50 [Worker_10001] Error: Can't locate object method "priority" 
via package "threads" at sub ASSP::Priority::new line 11.

 Apr-13-18 11:58:50 [Worker_10001] Info: RebuildSpamdb Scheduler stopped

 Apr-13-18 11:58:50 [Worker_10001] Info: starting RebuildSpamdb Scheduler with 
'00 01 * * *' - next RebuildSpamdb is scheduled for Apr-14-18 01:00:00

 Apr-13-18 11:58:55 [Worker_10001] Start rebuildAddCorrections

 Apr-13-18 11:58:55 [Worker_10001] Error: Can't locate object method "priority" 
via package "threads" at sub ASSP::Priority::new line 11.

 Apr-13-18 11:58:55 [Worker_10001] Info: RebuildSpamdb Scheduler stopped

 Apr-13-18 11:58:55 [Worker_10001] Info: starting RebuildSpamdb Scheduler with 
'00 01 * * *' - next RebuildSpamdb is scheduled for Apr-14-18 01:00:00

 Apr-13-18 11:59:00 [Worker_10001] Start rebuildAddCorrections

 Apr-13-18 11:59:00 [Worker_10001] Error: Can't locate object method "priority" 
via package "threads" at sub ASSP::Priority::new line 11.

 Apr-13-18 11:59:00 [Worker_10001] Info: RebuildSpamdb Scheduler stopped

 Apr-13-18 11:59:00 [Worker_10001] Info: starting RebuildSpamdb Scheduler with 
'00 01 * * *' - next RebuildSpamdb is scheduled for Apr-14-18 01:00:00

 Apr-13-18 11:59:05 [Worker_10001] Start rebuildAddCorrections

 Apr-13-18 11:59:05 [Worker_10001] Error: Can't locate object method "priority" 
via package "threads" at sub ASSP::Priority::new line 11.

 Apr-13-18 11:59:05 [Worker_10001] Info: RebuildSpamdb Scheduler stopped

 Apr-13-18 11:59:05 [Worker_10001] Info: starting RebuildSpamdb Scheduler with 
'00 01 * * *' - next RebuildSpamdb is scheduled for Apr-14-18 01:00:00

 Apr-13-18 11:59:10 [Worker_10001] Start rebuildAddCorrections

 Apr-13-18 11:59:10 [Worker_10001] Error: Can't locate object method "priority" 
via package "threads" at sub ASSP::Priority::new line 11.

 Apr-13-18 11:59:10 [Worker_10001] Info: RebuildSpamdb Scheduler stopped

 Apr-13-18 11:59:10 [Worker_10001] Info: starting RebuildSpamdb Scheduler with 
'00 01 * * *' - next RebuildSpamdb is scheduled for Apr-14-18 01:00:00


The modules loaded are:
Module Name

Module Version

Module Status

Download

show module load errors

installed / required(recommended)

show all loaded modules



ASSP_FC

not installed / 1.05

is not installed

sourceforge<http://sourceforge.net/p/assp/svn/HEAD/tree/assp2/trunk/filecommander/>

ASSP_SVG

1.03 / 1.03

enabled

sourceforge<http://sourceforge.net/p/assp/svn/HEAD/tree/assp2/trunk/lib/>

ASSP_WordStem

not installed / 1.27

is not installed

sourceforge<http://sourceforge.net/p/assp/svn/HEAD/tree/assp2/trunk/lib/>

AsspSelfLoader

2.03 / 2.03

enabled

sourceforge<http://sourceforge.net/p/assp/svn/HEAD/tree/assp2/trunk/lib/>

Authen::SASL

2.16 / 2.16

enabled

CPAN<http://search.cpan.org/search?query=Authen::SASL>

BerkeleyDB

not installed / 0.42

is not installed

CPAN<http://search.cpan.org/search?query=BerkeleyDB>

BerkeleyDB_DBEngine

/ 4.5

status unknown

oracle<http://www.oracle.com/technology/products/berkeley-db/>

Compress::Zlib

2.068 / 2.069

enabled

CPAN<http://search.cpan.org/search?query=Compress::Zlib>

Convert::TNEF

disabled by Module Setup<http://192.168.50.4:55555/#useConvertTNEF> / 0.17

is disabled in config

CPAN<http://search.cpan.org/search?query=Convert::TNEF>

DB_File

disabled by Module Setup<http://192.168.50.4:55555/#useDB_File> / 1.816

is disabled in config

CPAN<http://search.cpan.org/search?query=DB_File>

Digest::MD5

2.54 / 2.54

enabled

CPAN<http://search.cpan.org/search?query=Digest::MD5>

Digest::SHA1

not installed / 2.13

is not installed

CPAN<http://search.cpan.org/search?query=Digest::SHA1>

Email::MIME

1.937 / 1.936

enabled

CPAN<http://search.cpan.org/search?query=Email::MIME>

Email::Send

not installed / 2.201

is not installed

CPAN<http://search.cpan.org/search?query=Email::Send>

File::ReadBackwards

1.05 / 1.05

enabled

CPAN<http://search.cpan.org/search?query=File::ReadBackwards>

File::Scan::ClamAV

disabled by Module Setup<http://192.168.50.4:55555/#useFileScanClamAV> / 1.93

is disabled in config

CPAN<http://search.cpan.org/search?query=File::Scan::ClamAV>

HTML::Strip

/ 2.10

enabled

CPAN<http://search.cpan.org/search?query=HTML::Strip>

IO::Poll

0.09 / 0.07

enabled

CPAN<http://search.cpan.org/search?query=IO::Poll>

IO::Select

1.22 / 1.21

enabled

CPAN<http://search.cpan.org/search?query=IO::Select>

IO::Socket::INET6

not installed / 2.67

is not detected ( enableINET6 is not set )

CPAN<http://search.cpan.org/search?query=IO::Socket::INET6>

IO::Socket::SSL

2.024 / 2.020

no certificate found

CPAN<http://search.cpan.org/search?query=IO::Socket::SSL>

LWP::Simple

6.15 / 6.13

enabled

CPAN<http://search.cpan.org/search?query=LWP::Simple>

MIME::Types

2.12 / 2.11

enabled

CPAN<http://search.cpan.org/search?query=MIME::Types>

Mail::DKIM::Verifier

0.4 / 0.38

enabled

CPAN<http://search.cpan.org/search?query=Mail::DKIM::Verifier>

Mail::SPF

2.009 / 2.009

enabled

CPAN<http://search.cpan.org/search?query=Mail::SPF>

Mail::SPF::Query

not installed / 1.999001

is not installed

CPAN<http://search.cpan.org/search?query=Mail::SPF::Query>

Mail::SRS

disabled by Module Setup<http://192.168.50.4:55555/#useMailSRS> / 0.31

is disabled in config

CPAN<http://search.cpan.org/search?query=Mail::SRS>

Net::CIDR::Lite

0.21 / 0.21

enabled

CPAN<http://search.cpan.org/search?query=Net::CIDR::Lite>

Net::DNS

0.81 / 1.06

enabled

CPAN<http://search.cpan.org/search?query=Net::DNS>

Net::IP

1.56 / 1.56

enabled

CPAN<http://search.cpan.org/search?query=Net::IP>

Net::LDAP

0.65 / 0.65

enabled

CPAN<http://search.cpan.org/search?query=Net::LDAP>

Net::SMTP

3.05 / 3.07

enabled

CPAN<http://search.cpan.org/search?query=Net::SMTP>

Net::SMTP::SSL

1.02 / 1.01

enabled

CPAN<http://search.cpan.org/search?query=Net::SMTP::SSL>

Net::SSLeay

1.72 / 1.72

enabled

CPAN<http://search.cpan.org/search?query=Net::SSLeay>

NetAddr::IP::Lite

1.56 / 1.56

enabled

CPAN<http://search.cpan.org/search?query=NetAddr::IP::Lite>

NetSNMP::agent

disabled by Module Setup<http://192.168.50.4:55555/#useNetSNMPagent> / 5.05

is disabled in config

CPAN<http://search.cpan.org/search?query=NetSNMP::agent>

OpenSSL 1.0.2g

1.0.2g / 0.9.8

enabled

OpenSSL<https://www.openssl.org/>

PerlIO::scalar

0.23 / 0.14_01

enabled

CPAN<http://search.cpan.org/search?query=PerlIO::scalar>

Regexp::Optimizer

not installed / 0.23

is not installed

CPAN<http://search.cpan.org/search?query=Regexp::Optimizer>

Schedule::Cron

1.01 / 1.01

enabled

CPAN<http://search.cpan.org/search?query=Schedule::Cron>

Sys::CpuAffinity

not installed / 1.06

is not installed

CPAN<http://search.cpan.org/search?query=Sys::CpuAffinity>

Sys::MemInfo

not installed / 0.91

is not installed

CPAN<http://search.cpan.org/search?query=Sys::MemInfo>

Sys::Syslog

0.33 / 0.25

enabled

CPAN<http://search.cpan.org/search?query=Sys::Syslog>

Text::Unidecode

not installed / 1.27

is not installed

CPAN<http://search.cpan.org/search?query=Text::Unidecode>

Thread::Queue

3.05 / 3.07

enabled

CPAN<http://search.cpan.org/search?query=Thread::Queue>

Thread::State

not installed / 0.09

is not installed

CPAN<http://search.cpan.org/search?query=Thread::State>

Tie::RDBM

0.73 / 0.73

enabled

CPAN<http://search.cpan.org/search?query=Tie::RDBM>

Time::HiRes

1.9726 / 1.9726

enabled

CPAN<http://search.cpan.org/search?query=Time::HiRes>

Unicode::GCString

not installed / 2013.10

is not installed

CPAN<http://search.cpan.org/search?query=Unicode::GCString>

threads

2.01 / 2.02

enabled

CPAN<http://search.cpan.org/search?query=threads>

threads::shared

1.48 / 1.48

enabled

CPAN<http://search.cpan.org/search?query=threads::shared>


I ran the perl script to download the modules, but there are still some showing 
up not installed.  I didn't know if that could be what is keeping the process 
from running. If anyone has any suggestions for me to try I would appreciate it.
Thank you,
John
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Assp-test mailing list
Assp-test@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/assp-test

Reply via email to