We upgraded to cvs-head a couple of days ago, but haven't changed the config files at all.

Prior to the upgrade, all inbound calls to our call queues were recorded, and the filename was like "agent-6043-1109793719-24472.gsm". After the upgrade, the filename is now "1109793719-24472.gsm"

What do I need to change, (or can I) to get back to the "old" naming convention - it was really useful to see the agent number as part of the filename.

I've been poking around the source code to no avail - in chan_agent I've put some diagnostics around:

agent_read: line 487 ..

        if (recordagentcalls && f == &answer_frame)
        {
                ast_verbose(VERBOSE_PREFIX_3 "starting to monitor");
                agent_start_monitoring(ast,0);
        }


but I never get the "starting to monitor" notice appear. If I move it out of the if statement, the message does appear on the console. So this would seem to indicate that the f == &answer_frame is never true (recordagentcalls is -1, I did check that).

My knowledge of C is very limited ... as you can guess.

Help would be most appreciated.

Julian
_______________________________________________
Asterisk-Dev mailing list
[email protected]
http://lists.digium.com/mailman/listinfo/asterisk-dev
To UNSUBSCRIBE or update options visit:
  http://lists.digium.com/mailman/listinfo/asterisk-dev

Reply via email to