Hi,
I  have had alot of issues in asterisk 13 on different servers, we use them 
mostly for webrtc, confbridge and upgrading to 15 has not yet failed us after 1 
month or so.

/ Marcus

Från: asterisk-users-boun...@lists.digium.com 
[mailto:asterisk-users-boun...@lists.digium.com] För Patrick Wakano
Skickat: den 21 februari 2018 23:34
Till: Asterisk Users Mailing List - Non-Commercial Discussion 
<asterisk-users@lists.digium.com>
Ämne: Re: [asterisk-users] Asterisk crash on core show channel

Thanks for you answer Marcus,
So maybe this means some bug was fixed? Anyone aware of something related?
From the release notes, I couldn't find any direct change that could fix 
this....

Thanks,
Kind regards,
Patrick Wakano

On 21 February 2018 at 20:29, Marcus Kvarsell 
<marcus.kvars...@fogwise.se<mailto:marcus.kvars...@fogwise.se>> wrote:
Hello, i found upgrading to asterisk 15 helped.

Från: 
asterisk-users-boun...@lists.digium.com<mailto:asterisk-users-boun...@lists.digium.com>
 
[mailto:asterisk-users-boun...@lists.digium.com<mailto:asterisk-users-boun...@lists.digium.com>]
 För Patrick Wakano
Skickat: den 21 februari 2018 04:29
Till: Asterisk Users Mailing List - Non-Commercial Discussion 
<asterisk-users@lists.digium.com<mailto:asterisk-users@lists.digium.com>>
Ämne: [asterisk-users] Asterisk crash on core show channel

Hello Asterisk list,
I am facing some Asterisk crashes which are consistently pointing to the same 
backtrace, which is the following (using DONT_OPTIMIZE, BETTER_BACKTRACES and 
MALLOC_DEBUG):
Thread 1 (Thread 0x7f1f08be8700 (LWP 1767)):
#0  0x00007f1f9bed3395 in __strcasecmp_l_sse42 () from /lib64/libc.so.6
#1  0x00000000004a91ca in cdr_object_get_by_name_cb ()
#2  0x0000000000463c60 in internal_ao2_traverse ()
#3  0x0000000000463fc3 in __ao2_callback ()
#4  0x00000000004a9b7d in cdr_object_get_by_name ()
#5  0x00000000004a9d80 in ast_cdr_serialize_variables ()
#6  0x00000000004de411 in handle_showchan ()
#7  0x00000000004e15a5 in ast_cli_command_full ()
#8  0x00000000004e175b in ast_cli_command_multiple_full ()
#9  0x0000000000455246 in netconsole ()
#10 0x000000000060f192 in dummy_start ()
#11 0x00007f1f9cd3b9d1 in start_thread () from /lib64/libpthread.so.0
#12 0x00007f1f9be908fd in clone () from /lib64/libc.so.6
So this happens after issuing a "core show channel <channel>". This command is 
being executed by one script that periodically checks the channels and some of 
its variables. Thing is that sometimes the channel has something which causes 
this crash (happens around 2 times per month). Does anyone have any idea of 
what may be happening/wrong?
I am running Asterisk version 13.6.0 on CentOS 6.6 kernel 2.6.32-504.el6.x86_64 
and on CentOS 6.9 kernel 2.6.32-696.el6.x86_64.
Any idea is very appreciated!
Best regards,
Patrick Wakano


<http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>

Virus-free. www.avg.com 
<http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>

 
<http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>

--
_____________________________________________________________________
-- Bandwidth and Colocation Provided by http://www.api-digital.com --

Check out the new Asterisk community forum at: https://community.asterisk.org/

New to Asterisk? Start here:
      https://wiki.asterisk.org/wiki/display/AST/Getting+Started

asterisk-users mailing list
To UNSUBSCRIBE or update options visit:
   
http://lists.digium.com/mailman/listinfo/asterisk-users<http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>
 
<http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>
-- 
_____________________________________________________________________
-- Bandwidth and Colocation Provided by http://www.api-digital.com --

Check out the new Asterisk community forum at: https://community.asterisk.org/

New to Asterisk? Start here:
      https://wiki.asterisk.org/wiki/display/AST/Getting+Started

asterisk-users mailing list
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-users

Reply via email to