We've found the problem.

For anyone seeing this same problem in the future, the underlying problem was a miss-placed entry in our pjsip.conf


If this is set, any changes to Remote-Party-ID are ignored, even when CONNECTEDLINE(num) is called in the dialplan.  I don't know if this is desired behavior or not, but it's how pjsip seems to work.

On 4/6/23 2:54 PM, Steve Sether wrote:

We've been using Asterisk 16 for a while now, and tried turning on send_rpid = yes in my pjsip config for end points.  This solves a problem we're having where attended transfers aren't updating the CallerID when the transfer is complete (it would show the callerID of the party attempting the transfer, and never update after the transfer happened).

The side effect of this change is that now on all outgoing calls, the phone I placed the call on shows 0 as the dialed number, which is wrong of course.  This shows up in a pcap to the phone that dialed as a re-invite sent back to it (before the call even connects), and shows something like:

Remote-Party-ID: <sip:0...@hostname-here.com;user=phone>;party=called;privacy=off;screen=no

I'm not really certain why Asterisk is setting a Remote-Party-ID to 0, which I believe is the default.  Clearly it knows who it's calling.   I could fix this by explicitly setting the header, but that seems wrong, and Asterisk should be setting this correctly.

Any help is appreciated.  I've gone through a bunch of different attempts to fix this by changing pjsip settings (none worked), but in the end I don't know why Asterisk sets this header so wrong.

We're using Asterisk 16.30, and of course pjsip.


-- Bandwidth and Colocation Provided by http://www.api-digital.com --

Check out the new Asterisk community forum at: https://community.asterisk.org/

New to Asterisk? Start here:

asterisk-users mailing list
To UNSUBSCRIBE or update options visit:

Reply via email to