On 5/26/2023 5:41 PM, Steve Matzura wrote:
> Doug from this list got me to change my connectivity to my DID provider
> from SIP to IAX, and bingo, it all just worked instantly.

Looking over your previous messages and the error you were receiving
(the one referring to extension 's') it looks like you had your
VoIP.ms account setting incorrectly configured. There is a "Device
type" dropdown that needs to be set to "IP PBX Server, Asterisk, or
Softswitch." If instead it is set to "ATA device, IP Phone or
Softphone" (the default) then it will be sent to the 's' extension
instead of the DID one. I captured a screenshot┬╣ from my account.

I created a VoIP.ms account, acquired a DID, copy/pasted the VoIP.ms
configuration samples┬▓, substituted my SIP Account User ID and
passwords, restarted Asterisk, and everything worked as expected.

I would never recommend new installs use IAX2, so if you envision this
moving beyond the toy/PoC stage I suggest you giving PJSIP another go.

Kind regards,

1. https://seanbright.com/voipms.png
2. https://wiki.voip.ms/article/Asterisk_PJSIP

-- Bandwidth and Colocation Provided by http://www.api-digital.com --

Check out the new Asterisk community forum at: https://community.asterisk.org/

New to Asterisk? Start here:

asterisk-users mailing list
To UNSUBSCRIBE or update options visit:

Reply via email to