On 13.10.2016 16:20, Valo, Kalle wrote:
Jiří Prchal <jiri.prc...@aksignal.cz> writes:

On 13.10.2016 15:00, Valo, Kalle wrote:
Jiří Prchal <jiri.prc...@aksignal.cz> writes:

$dmesg | grep ath
[    1.997246] ath10k_pci 0000:02:00.0: pci irq msi interrupts 1 irq_mode 0 
reset_mode 0
[    2.252840] ath10k_pci 0000:02:00.0: Direct firmware load for 
ath10k/cal-pci-0000:02:00.0.bin failed with error -2
[    2.260813] ath10k_pci 0000:02:00.0: Direct firmware load for 
ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2
[    2.260816] ath10k_pci 0000:02:00.0: could not fetch firmware file 
'ath10k/QCA6174/hw3.0/firmware-5.bin': -2

So ignore this firmware-5.bin warning, ath10k will automatically fall
back to using firmware-4.bin. I know it's confusing, we just haven't
found a good enough way to silence this warning yet.

OK. Maybe temporary fix: write info message what firmware is finally

That's a good idea. Developers can already see that from the "fwapi 4"
print but somekind of explanation in english should reduce the confusion
with normal users.

[    4.461429] ath10k_pci 0000:02:00.0: qca6174 hw3.2 (0x05030000,
0x00340aff sub 1043:86cd) fw WLAN.RM.2.0-00180-QCARMSWPZ-1 fwapi 4
bdapi 2 htt-ver 3.26 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0
hwcrypto 1 features wowlan,ignore-otp,no-4addr-pad

Your ath10k is too old so that it doesn't print the crc32 checksum of
the board file you have so I don't know what version of the board file
you exactly have. But I just checked, the latest one from
ath10k-firmware.git should support your board with subsystem id

Should I try the newest kernel?

That's always a good idea, for example you could try just released v4.8.
Does ubuntu still provide .debs for upstream kernels?

I tried 4.8.1 and it works now, but probably it worked before, because I set AP 
to channel 13 and it was the problem.

Or you can try backports:


Backports are up to 4.2.

$ strings QCA6174/hw3.0/board-2.bin | grep 86cd

The checksums of the latest board file are:

FileCRC32: 6fc88fe7
FileMD5: 4807903c956dbd8b87f5d83c559c2211

You can check what you are using like this:

md5sum /lib/firmware/ath10k/QCA6174/hw3.0/board-2.bin

Yes, I have the newest: 4807903c956dbd8b87f5d83c559c2211.

Then I suspect this is something else than board file related, but of
course I can't be 100% sure. You could also try enabling debug messages
and see if they reveal anything, for example debug_mask=0x00000432 is a
good start:


Have you verified that this is not a hardware problem? For example, does
the board work on Windows?

Also make sure that you have killed wpasupplicant, network-manager or
any other entity which might control the wireless device (very unlikely
that would cause this but better to be sure).

What channel is your AP in? Are there multiple APs in the area? This
could be also a channel problem, 'iw list' helps to investigate that (or
changing the channel on AP).

As I wrote the problem was channel. However it should work cause I set country 
to CZ.
May be I should open new thread?

ath10k mailing list

Reply via email to