On Tue, 2018-06-12 at 14:40 +0300, Kalle Valo wrote:
> Timur Kristóf <timur.kris...@gmail.com> writes:
> 
> > On Fri, 2018-06-08 at 11:32 -0700, Ryan Hsu wrote:
> > > In the case of Station connects to AP with narrower bandwidth at
> > > beginning.
> > > And later the AP changes the bandwidth to winder bandwidth, the
> > > AP
> > > will
> > > beacon with wider bandwidth IE, eg VHT20->VHT40->VHT80 or VHT40-
> > > > VHT80.
> > > 
> > > Since the supported BANDWIDTH will be limited by the PHYMODE, so
> > > while
> > > Station receives the bandwidth change request, it will also need
> > > to
> > > reconfigure the PHYMODE setting to firmware instead of just
> > > configuring
> > > the BANDWIDTH info, otherwise it'll trigger a firmware crash with
> > > non-support bandwidth.
> > > 
> > > The issue was observed in WLAN.RM.4.4.1-00051-QCARMSWP-1, QCA6174
> > > with
> > > below scenario.
> 
> [...]
> 
> > I can confirm that this patch works on my machine, and prevents the
> > crash previously caused by changing the bandwidth.
> 
> Great, thanks a lot for working on this. I'll add your Tested-by to
> the
> commit log.

Thanks!

> > Can it be accepted, or is there anything I can help with, to get it
> > accepted?
> 
> Strangely I can't find Timur's version of the patch from patchwork:
> 
> https://patchwork.kernel.org/project/linux-wireless/list/?state=*
> 
> Maybe it got dropped due to some UTF-8 problems? patchwork is known
> to
> be problematic with UTF-8.

Not sure. It doesn't really matter now, Ryan's version is fine too.

> Anyway, I'll queue Ryan's v2 to 4.18. It first goes to the pending
> branch for build testing and from there to ath-current branch.

Awesome, thank you Kalle!

Best regards,
Tim

_______________________________________________
ath10k mailing list
ath10k@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/ath10k

Reply via email to