Hi Sujith,

Any update on this problem?
I tried it on .31-rc9 (using ubuntu's ubuntu-karmic.git - which is
rebased to -rc9) again, and the problem still exists.

As I mentioned earlier, the driver absolutely drops the WLAN
connection when subjected to network IO (apparently, anything >10MiB
cannot be transferred over the network without rmmod + modprobe
exercise a couple of times).

Last night, I tried to scp a 60MiB tar from desktop to laptop - I had
to rmmod + modprobe the driver twice.
It gives good speeds when the transfer starts initially; but as it
progresses, the transfer speed keeps dropping to really unusable
levels - just a few (<10) KiB's per second. :(

The same file when scp'ed from Vista (pre-installed on the laptop) has
absolutely no problems - gets over in ~1min - maybe even less - I
didn't see the actual clock time; but it's measurably low wrt linux.

Are there any patches that you'd like me to try on top of the
mainline/ubuntu's tree?


On Tue, Aug 25, 2009 at 2:28 AM, Kunal Gangakhedkar
<kunal.gangakhed...@gmail.com> wrote:
> On Wednesday 19 Aug 2009 9:21:13 am Sujith wrote:
>> Kunal Gangakhedkar wrote:
>> > Any way we can help debug this issue?
>> > It gets really annoying when the driver goes berserk in the middle of a
>> > big file transfer - even on LAN. :(
>> >
>> > rmmod'ing and modprobe'ing the driver again seems to get it working; but,
>> > as the network load increases, the driver again starts faltering.
>> >
>> > The problem starts especially under load on the network - say, while
>> > transferring ISOs from desktop to laptop, or updating ubuntu packages.
>> >
>> > When the driver exhibits the problem, the ping times on the LAN also go
>> > berserk - ranging from ~1ms to ~700ms while sitting next to the wireless
>> > router (Linksys WRT54GL running OpenWRT Kamikaze 8.09) with packets lost.
>> > The router is working fine because my other laptop (IBM Thinkpad R51
>> > running ipw2200) never has any problems with the WLAN.
>> >
>> > I'm using linux kernel 2.6.31-4-generic (x86_64) on kubuntu jaunty on
>> > this new HP laptop (dv6 series). The kernel is built by myself from
>> > ubuntu-karmic.git (git://kernel.ubuntu.com/ubuntu/ubuntu-karmic.git)
>> >
>> > Config options related to ath9k in the kernel:
>> >
>> > ku...@plutonium:/boot$ grep 'CONFIG_ATH9K' config-2.6.31-4-generic
>> Can you load the driver with the modparam 'debug=0x200' and post the kernel
>> log when this issue happens ? Thanks.
>> Sujith
> Attaching the gzipped log with ath9k loaded with modparam "debug=0x200".
> The commands I used to get the logs are:
> $ grep -P "(ath(9k)?|wlan)" /var/log/kern.log > ~/ath9k.log
> $ gzip -9 ath9k.log
> Please let me know if anything more is needed.
> Kunal
ath9k-devel mailing list

Reply via email to