I forgot to mention that I tried that too.  It works.  It prints

Icon theme "gnome" not found.
Icon theme "gnome" not found.
Icon theme "gnome" not found.

... but opens the requested document in a PDF viewer.

It's only when I try TeX-documentation-texdoc that I have the problem.  

On Fri 20 Jan 2023 at 15:52 David Kastrup wrote:
> Greg Bognar via General discussion about AUCTeX <auctex@gnu.org> writes:
> > Hi,
> >
> > When I run `TeX-documentation-texdoc' (from the menu or with C-c ?), nothing
> > happens.  The mouse pointer does turn into busy, but it stops after a while.
> > Nothing is written to *Messages* or to .xsession-errors.
> >
> > The texdoc command works from the terminal, opening a PDF viewer with the
> > requested document.
> >
> > I'm not sure whether this is an AUCTeX, Emacs, or window manager issue.  Any
> > ideas how I could find out what the problem is?
> Try M-x shell RET and run texdoc from _that_ command line.  That should at
> least carry around some of the environment that TeX-documentation-texdoc is
> working with.  If it fails, you'll probably get some info in the Emacs buffer
> used as terminal.
> -- 
> David Kastrup

Reply via email to