On Thu, Apr 6, 2023 at 8:27 PM Arash Esbati <ar...@gnu.org> wrote:
> Hongyi Zhao <hongyi.z...@gmail.com> writes:
> > While loading auctex, the following problem occurred:
> >
> > Loading 
> > /home/werner/.emacs.d/straight/repos/auctex/style/listings.elc...done
> > font-lock-compile-keywords: Font-lock trying to use keywords before
> > setting them up
> I have no idea about straight, but you can start Emacs with '-Q', eval
> this in scratch
>   (setq TeX-data-directory "/home/werner/.emacs.d/straight/repos/auctex"
>         TeX-lisp-directory TeX-data-directory)
>   (load "/home/werner/.emacs.d/straight/repos/auctex/auctex.el" nil t t)
>   (setq debug-on-error t)
> and open a .tex file and see what happens.

I tried you above advice and opened the same .tex file, but this time
the same error didn't occur. Below is the content shown in *Messages*

For information about GNU Emacs and the GNU system, type C-h C-a.
Mark set
t [2 times]
Applying style hooks...done
Sorting LaTeX-environment...done
Removing duplicates...done
Beginning of buffer [2 times]
Mark set

> Best, Arash


Reply via email to