o current problems
- setting inode number which was previously assigned ("broken ino"
  msg) (fixed).
- getdents(2) returns nothing. (fixed)
- cpup_wh_file() failure. (fixed)

o bugfix
- bugfix: cpup whiteout which was called #2 in last ci.

o news
- begin supporting linux-2.6.22
  + introduce lhash patch for 2.6.22.
  + no more ksize.patch.
- introduce new branch permission 'rr.'
  + rename au_is_ro() to au_is_rr().
- introduce new (re)mount option, 'verbose' family, currenlty for
  deleting a branch only.
- support MagicSysRq key for debugging.

o misc
- testing CONFIG_AUFS_ROBR.
- testing new mount option for 'refreshing opened file'
  + a generation to branch.
  + typedef for every generation data.
  + stop packing branch id and si generation.
  + return of 'coo' option.
- discard pre-allocated block for xino bitmap.
- add a note about unmouting ore remounting root aufs at shutdown
  time.
- minor optimization for handling udba=inotify.
- rename hi_lock_XXX() to vfsub_i_lock_nested().
- rename hi_unlock() to vfsub_i_unlock().
- print inotify info for inode.
- move lock subclasses from hinode.h to vfsub.h.


Junjiro Okajima

----------------------------------------------------------------------

Index: Kconfig.in
- testing CONFIG_AUFS_ROBR.
- begin supporting linux-2.6.22
  + introduce lhash patch for 2.6.22.

Index: fs/aufs/aufs.h
- begin supporting linux-2.6.22
  + no more ksize.patch.

Index: fs/aufs/branch.c
- introduce new branch permission 'rr.'
  + rename au_is_ro() to au_is_rr().
- rename hi_lock_XXX() to vfsub_i_lock_nested().
- rename hi_unlock() to vfsub_i_unlock().
- testing new mount option for 'refreshing opened file'
  + a generation to branch.
  + typedef for every generation data.
- introduce new (re)mount option, 'verbose' family, currenlty for
  deleting a branch only.

Index: fs/aufs/branch.h
- begin supporting linux-2.6.22
  + introduce lhash patch for 2.6.22.
- testing new mount option for 'refreshing opened file'
  + a generation to branch.
- introduce new branch permission 'rr.'
  + rename au_is_ro() to au_is_rr().

Index: fs/aufs/cpup.c
Index: fs/aufs/f_op.c
Index: fs/aufs/i_op_ren.c
- minor optimization for handling udba=inotify.
- rename hi_lock_XXX() to vfsub_i_lock_nested().
- rename hi_unlock() to vfsub_i_unlock().

Index: fs/aufs/debug.c
- support MagicSysRq key for debugging.
- begin supporting linux-2.6.22
  + no more ksize.patch.
- print inotify info for inode.

Index: fs/aufs/debug.h
- support MagicSysRq key for debugging.
- introduce new (re)mount option, 'verbose' family, currenlty for
  deleting a branch only.

Index: fs/aufs/dentry.c
- rename hi_lock_XXX() to vfsub_i_lock_nested().
- rename hi_unlock() to vfsub_i_unlock().
- minor optimization for handling udba=inotify.
- testing new mount option for 'refreshing opened file'
  + typedef for every generation data.

Index: fs/aufs/dentry.h
Index: fs/aufs/file.h
Index: fs/aufs/inode.h
Index: fs/aufs/misc.h
Index: fs/aufs/sbinfo.c
- testing new mount option for 'refreshing opened file'
  + typedef for every generation data.

Index: fs/aufs/dir.c
Index: fs/aufs/i_op_add.c
Index: fs/aufs/plink.c
- rename hi_lock_XXX() to vfsub_i_lock_nested().
- rename hi_unlock() to vfsub_i_unlock().

Index: fs/aufs/export.c
- testing new mount option for 'refreshing opened file'
  + typedef for every generation data.
  + stop packing branch id and si generation.

Index: fs/aufs/file.c
- minor optimization for handling udba=inotify.
- testing new mount option for 'refreshing opened file'
  + return of 'coo' option.
  + typedef for every generation data.
- rename hi_lock_XXX() to vfsub_i_lock_nested().
- rename hi_unlock() to vfsub_i_unlock().
- bugfix: cpup whiteout which was called #2 in last ci.

Index: fs/aufs/hinode.h
- move lock subclasses to vfsub.h.
- rename hi_lock_XXX() to vfsub_i_lock_nested().
- rename hi_unlock() to vfsub_i_unlock().

Index: fs/aufs/i_op.c
- rename hi_lock_XXX() to vfsub_i_lock_nested().
- rename hi_unlock() to vfsub_i_unlock().
- minor optimization for handling udba=inotify.
- bugfix: cpup whiteout which was called #2 in last ci.

Index: fs/aufs/i_op_del.c
Index: fs/aufs/iinfo.c
- minor optimization for handling udba=inotify.

Index: fs/aufs/misc.c
- begin supporting linux-2.6.22
  + no more ksize.patch.
- rename hi_lock_XXX() to vfsub_i_lock_nested().
- rename hi_unlock() to vfsub_i_unlock().

Index: fs/aufs/module.c
- support MagicSysRq key for debugging.
- begin supporting linux-2.6.22
  + no more ksize.patch.

Index: fs/aufs/module.h
Index: fs/aufs/sysaufs.h
- support MagicSysRq key for debugging.

Index: fs/aufs/opts.c
- introduce new (re)mount option, 'verbose' family, currenlty for
  deleting a branch only.
- testing new mount option for 'refreshing opened file'
  + return of 'coo' option.
- introduce new branch permission 'rr.'
- minor optimization for handling udba=inotify.

Index: fs/aufs/opts.h
- testing new mount option for 'refreshing opened file'
  + return of 'coo' option.

Index: fs/aufs/super.c
- introduce new (re)mount option, 'verbose' family, currenlty for
  deleting a branch only.
- testing new mount option for 'refreshing opened file'
  + return of 'coo' option.
  + typedef for every generation data.

Index: fs/aufs/super.h
- testing new mount option for 'refreshing opened file'
  + typedef for every generation data.
- introduce new (re)mount option, 'verbose' family, currenlty for
  deleting a branch only.
- minor optimization for handling udba=inotify.

Index: fs/aufs/vfsub.h
- move lock subclasses from hinode.h.

Index: fs/aufs/xino.c
- rename hi_lock_XXX to vfsub_i_lock_nested().
- rename hi_unlock() to vfsub_i_unlock().
- discard pre-allocated block for xino bitmap.

Index: util/aufs.in.5
- introduce new (re)mount option, 'verbose' family, currenlty for
  deleting a branch only.
- testing new mount option for 'refreshing opened file'
  + return of 'coo' option.
- support MagicSysRq key for debugging.
- introduce new branch permission 'rr.'
- testing CONFIG_AUFS_ROBR.
- add a note about unmouting ore remounting root aufs at shutdown
  time.

Index: fs/aufs/Makefile
Index: fs/aufs/hinotify.c
Index: fs/aufs/inode.c
Index: include/linux/aufs_type.h
- less important changes.

-------------------------------------------------------------------------
This SF.net email is sponsored by DB2 Express
Download DB2 Express C - the FREE version of DB2 express and take
control of your XML. No limits. Just data. Click to get it now.
http://sourceforge.net/powerbar/db2/

Reply via email to