On Thu, 22 Feb 2018 19:45:48 +0530
Ankit R Gadiya <a...@argp.in> wrote:

> Hi everyone,
> 
> I added two new PKGBUILD(s) today in the AUR, both are plugins for vim.
> Any advice, suggestions or feedback will be greatly appreciated.
> And if anybody would like the *-git versions of these I will be more
> then happy to add them as well.
> 
> 1. ranger-vim: https://aur.archlinux.org/packages/ranger-vim/
> 2. tcomment-vim: https://aur.archlinux.org/packages/tcomment-vim/
> 
> Ranger-vim
> # Maintainer: Ankit R Gadiya <a...@argp.in>
> 
> pkgname=ranger-vim
> pkgver=2.0
> pkgrel=1
> pkgdesc="Ranger integration for vim"
> license=('MIT')

MIT license is required to be installed in the filesystem, but I don't see that
done below.

> arch=('any')
> url="https://github.com/francoiscabrol/ranger.vim";
> depends=('vim' 'ranger')
> groups=('vim-plugins')
> source=("https://github.com/francoiscabrol/${pkgname/-/.}/archive/${pkgver}.tar.gz";)

You need to rename this file. A file named "2.0.tar.gz" is far too generic if
people are using SRCDEST.

> md5sums=('59f24462eb5c7561756a646585cd9e4c')
> 
> package() {
>     install -Dm755 "${srcdir}/${pkgname/-/.}-${pkgver}/plugin/ranger.vim" \
>               "${pkgdir}/usr/share/vim/vimfiles/plugin/ranger.vim"

You can omit the ${srcdir} here if you'd like, functions will always start 
there.
You can also omit the last ranger.vim if you use the -t switch. Both of these 
are
optional.

> }
> 
> tcomment-vim
> # Maintainer: Ankit R Gadiya <a...@argp.in>
> 
> pkgname=tcomment-vim
> pkgver=3.08.1
> pkgrel=1
> pkgdesc="An extensible & universal comment vim-plugin that also
> handles embedded filetypes"

Is this a wrapping issue or is this really 2 lines?

> license=('GPL3')
> arch=('any')
> url="https://github.com/tomtom/tcomment_vim";
> depends=('vim')
> groups=('vim-plugins')
> source=("https://github.com/tomtom/${pkgname/-/_}/archive/${pkgver}.tar.gz";)

Same as with the other PKGBUILD

> md5sums=('6ea8f4ce78411efba444a0218e111219')
> 
> package() {
> 
>       install -d "${pkgdir}/usr/share/vim/vimfiles/"{doc,plugin,autoload}

This doesn't do anything. The -D switch on the following commands will take 
care of it.

> 
>       install -Dm755 "${srcdir}/${pkgname/-/_}-${pkgver}/plugin/tcomment.vim" 
> \
>               "${pkgdir}/usr/share/vim/vimfiles/plugin/tcomment.vim"
>       install -Dm755 "${srcdir}/${pkgname/-/_}-${pkgver}/doc/tcomment.txt" \
>               "${pkgdir}/usr/share/vim/vimfiles/doc/tcomment.txt"
>       install -Dm755 
> "${srcdir}/${pkgname/-/_}-${pkgver}/autoload/tcomment.vim" \
>               "${pkgdir}/usr/share/vim/vimfiles/autoload/tcomment.vim"

Same as other PKGBUILD.

> }
> 

Attachment: pgpRZw36HTynP.pgp
Description: OpenPGP digital signature

Reply via email to