On Sunday 04 November 2018 at 10:32:38 +0000, Mike Crowe wrote:
> * Function naming:
> Several proposals have been made for naming:

I only had one reply to the naming suggestions below, so I've combed
through prior emails looking for preferences there. I apologise if I missed
your preference. Please let me know! Results below.

> ** 1. clock prefix
>  sem_clock_timedwait
>  pthread_mutex_clock_timedlock
>  pthread_cond_clock_timedwait
>  pthread_rwlock_clock_timedrdlock
>  pthread_rwlock_clock_timedwrlock
>  mq_clock_timedreceive
>  mq_clock_timedsend

Preferred by SC (in private email)

> ** 2. timed->clock
>  sem_clockwait
>  pthread_mutex_clocklock
>  pthread_rwlock_clockrdlock
>  pthread_rwlock_clockwrlock
>  mq_clockreceive
>  mq_clocksend
>  pthread_cond_clockwait

Preferred by Mark Harris, Daniel Eischen.

> ** 3. onclock suffix
>  sem_timedwait_onclock
>  pthread_mutex_timedlock_onclock
>  pthread_rwlock_timedrdlock_onclock
>  pthread_rwlock_timedwrlock_onclock
>  mq_timedreceive_onclock
>  mq_timedsend_onclock
>  pthread_cond_timedwait_onclock

Preferred by Tom Cherry (although I suspect that, like me, he's be happy
with either of the others too if it meant that the feature was added!)

> All guidance gratefully appreciated.

So, it looks like there isn't a clear favourite, but timed->clock has a
slight majority. I plan to enter a new defect report to supersede
http://austingroupbugs.net/view.php?id=1164 by covering all the above



Reply via email to