The name LAYER_OUTOFSPACE suggests that this is a real layer on which windows
can be put, but it's only used as an integer which describes the maximum
allowed / used layer.
Therefor, renaming it to LAYER_MAX and adding a comment which describes this
might make sense.

Signed-off-by: Uli Schlachter <psyc...@znc.in>
---
 client.c |    5 +++--
 1 files changed, 3 insertions(+), 2 deletions(-)

diff --git a/client.c b/client.c
index 0144c91..86ce39e 100644
--- a/client.c
+++ b/client.c
@@ -305,7 +305,8 @@ typedef enum
     LAYER_ABOVE,
     LAYER_FULLSCREEN,
     LAYER_ONTOP,
-    LAYER_OUTOFSPACE
+    /** This one only used for counting and is not a real layer */
+    LAYER_MAX
 } layer_t;

 /** Get the real layer of a client according to its attribute (fullscreen, …)
@@ -379,7 +380,7 @@ client_stack()
         }

     /* then stack clients */
-    for(layer = LAYER_BELOW; layer < LAYER_OUTOFSPACE; layer++)
+    for(layer = LAYER_BELOW; layer < LAYER_MAX; layer++)
         for(node = last; node; node = node->prev)
             if(client_layer_translator(node->client) == layer)
                 config_win_vals[0] = client_stack_above(node->client,
-- 
1.6.2.1

-- 
"Do you know that books smell like nutmeg or some spice from a foreign land?"
                                                  -- Faber in Fahrenheit 451

-- 
To unsubscribe, send mail to awesome-devel-unsubscr...@naquadah.org.

Reply via email to