Alexis: I think you're right; I just tested another keyboard with the same
setup, and its Mod4 key worked (strangely its function key did not

I doubt that the actual key has broken on my keyboard: it's mechanical, and
2 keys on opposite ends of the board breaking at once seems unlikely. So, I
think a recent update might have broken support for my keyboard.

I've been using this to provide support for the extra keys on the side of
my keyboard:

Up until now, this driver has worked well and I have never had any "broken"
keys like this before.  Nobody's made any commits to this for a few years,
so perhaps the driver is no longer compatible with newer linux kernels (I'm
using 4.6.3-1-ARCH).

I'll try the Mod4 key on another operating system later just to make sure
it isn't a physical problem.


On Wed, Jul 13, 2016 at 5:14 AM, Alexis BRENON <>

> Same idea. I xev doesn't report Mod4 events, it's probably deeper than an
> awesome config mistake, something related to X11, udev, etc. ?
> Le mer. 13 juil. 2016 à 08:04, Namikaze Minato <> a
> écrit :
>> The only think I can say is that the rc.lua change you described here
>> cannot have caused your mod key to stop working.
>> Did you try to see if your mod4 key works outside of the graphical
>> environment to try to understand what is happening?
>> Regards,
>> LLoyd
>> On 13 July 2016 at 04:39, Abraham Baker <>
>> wrote:
>> > Hi,
>> >
>> > My Mod4 (SuperL and R) keys stopped working today after I altered my
>> rc.lua
>> > to make switching client focus easier.
>> >
>> > All I did was to switch the default binding of "Mod4 + Control + j/k" to
>> > "Mod4 + Control + h/l" for changing the screen.focus_relative.  Using H
>> and
>> > L to move the focus left and right makes more intuitive sense to me
>> because
>> > my monitors are arranged linearly.
>> >
>> > I remembered to change the tag.incncol bindings as well, since they were
>> > already using Mod4 + Control + h/l.
>> >
>> > However, after making these changes, I now cannot use Mod4 at all (it
>> does
>> > not register in xev). If I restore the config to the way it was before,
>> Mod4
>> > still does not work. Switching to Alt (Mod1) works, but I would much
>> rather
>> > use Mod4 if possible.
>> >
>> > Any help in figuring out how to restore Mod4 functionality would be
>> greatly
>> > appreciated.
>> >
>> > Thanks,
>> > Aber
>> --
>> To unsubscribe, send mail to

Reply via email to