Just thought I'd inform y'all. We (Tom and Rich and Richard and I) decided to call this new service implementation a "Locator". It may seem a bit obscure at first, but the service stanza contains location information; and it makes a lot of sense when you look at the client code:
AddressBook ab = new AddressBookServiceLocator().getAddressBook(); I'll make sure the user's guide is updated appropriately. Russell Butek [EMAIL PROTECTED] Russell Butek/Austin/IBM@IBMUS on 02/05/2002 09:17:32 AM Please respond to [EMAIL PROTECTED] To: [EMAIL PROTECTED] cc: Subject: RE: Service interface I still stand by my argument, but I don't feel as strongly about it today. Two reasons: 1. I just went through 15 tests and changed names from XXX to XXXServiceImpl and all but 2 have the string "ServiceServiceImpl". Yuck. 2. I can't come up with a decent replacement for "Impl". Your suggestion about leaving off Impl and putting 'Interface" on something else won't work. The names of all the generated files are fixed by JAX-RPC except the skeleton and the 2 impls; and the binding name MAY be used for the SDI. I'm still not happy with your suggestion, but it may become the one I'm least unhappy with. I'M STILL HOPING SOMEONE CAN COME UP WITH A BETTER SUFFIX THAN "Impl"! Russell Butek [EMAIL PROTECTED] Tom Jordahl <[EMAIL PROTECTED]> on 02/05/2002 08:58:38 AM Please respond to [EMAIL PROTECTED] To: "'[EMAIL PROTECTED]'" <[EMAIL PROTECTED]> cc: Subject: RE: Service interface Well, he didn't sway me as much. :-) How about the rule: "the service implementation name ends with the string 'ServiceImpl'". I also am not a fan of having 2 "Impl" files. But I don't have any really good replacement names off the top of my head. Can we change one of the other file names to be called "Interface" and drop the Impl from its corresponding concrete java class? -- Tom Jordahl -----Original Message----- From: Russell Butek [mailto:[EMAIL PROTECTED]] Sent: Monday, February 04, 2002 5:08 PM To: [EMAIL PROTECTED] Subject: RE: Service interface Tom, I think Richard's swayed me. I don't think it's a good idea to make the rules complex. It should simply be "the service implementation is named <serviceName>ServiceImpl." Period. If we add "unless <serviceName> ends in Service, in which case it is <serviceName>Impl" then we lose clarity. With that said, I still don't particularly like "ServiceImpl". We happen to call both the implementation template generated for a binding an "Impl" and the concrete service implementation an "Impl". If we could call one or the other something else I'd be happy. Any ideas? binding impl: <bindingName>Template service impl: <serviceName>Impl binding impl: <bindingName>Impl service impl: Concrete<serviceName> binding impl: <bindingName>Impl service impl: <serviceName>Factory Russell Butek [EMAIL PROTECTED] Richard Sitze/Charlotte/IBM@IBMUS on 02/04/2002 09:39:46 AM Please respond to [EMAIL PROTECTED] To: [EMAIL PROTECTED] cc: Subject: RE: Service interface It's generated code. We are use to seeing "stupid names" coming from generated code :-). Seriously, when trying to figure out what the code generators are doing, minimizing the variences in generated names seems like the best choice. A "stupid" artificial name, yet no question on the intent or lineage of the name. <ras> ******************************************* Richard A. Sitze [EMAIL PROTECTED] Tom Jordahl <tomj@macromedia To: "'[EMAIL PROTECTED]'" .com> <[EMAIL PROTECTED]> cc: 02/04/2002 09:20 Subject: RE: Service interface AM Please respond to axis-dev Here is a suggestion: Check for "Service" at the end of the name, and don't append it if it's already there. This prevents the stupid name. Still avoids name clashes. -- Tom Jordahl -----Original Message----- From: Russell Butek [mailto:[EMAIL PROTECTED]] Sent: Monday, February 04, 2002 10:09 AM To: [EMAIL PROTECTED] Subject: Service interface JAX-RPC 0.6 discussed generating a service interface and a service implementation. The interface was optional. In the interests of minimizing generated files, AXIS opted to NOT generate the interface. In JAX-RPC 0.7 the service interface is no longer optional. If the service is named X, the service interface is named X. That's the name we'd been using for the implementation. I would like to rename the implementation to XServiceImpl. I will not simply rename it XImpl because I've occasionally seen a binding and a service share the same name and we already generate an implementation template called <bindingName>Impl. Of course, most often the service name is something like XService, so we'd be generating the rather strangely named class XServiceServiceImpl. I'd be happy to hear better suggestions if folks have them. Russell Butek [EMAIL PROTECTED]