Looking at the client-side of things for a moment...
Let's say someone wants to add a client-side handler
that's service specific. In the WSDD file they need to
specify the service name as the QName of the 1st body
element. This is, or could be I guess, contradictory to
how things will work on the server if people use the URLMapper.
Initially I was thinking that all I would need to do is add some
sort of URLMapper handler to the client side and then I
could put "stockquote" instead of "urn:delayed-quote..."
as the service name in the client-config.wsdd. But, alas,
that handler should be in the Transport chain which is run
after the service specific chain. Putting it in the global chain
(even though its http specific) wouldn't work either since that
too is run after the service specific chain.
Not sure what the solution is, just sort of thinking out loud
because I do think this is a problem. I don't think we should
change the current ordering of the client-side chains, I
think that's correct, but at the same time it seems like requiring
someone on the client to use the namespace as the service
name feels wrong. Maybe telling the client side programmer
to set the targetServiceName manually is the right way to go?
(Doesn't feel right though) Maybe the addition of a new chain
that gets executed between the Call.invoke() and the server
specific chain is needed? (feels like overkill)
Don't know - any ideas? Or do other people not see this
as a problem at all?
-Dug
- Re: client-side global chain dug
- Re: client-side global chain Glyn Normington
- Re: client-side global chain dug
- Re: client-side global chain sggraham