Hash: SHA1

Here's a brief update on this issue: After taking the automounter out of the
equation, and hard-mounting all file systems, the last differential did not
show the spurious warnings on crossing file-system boundaries.

Whether the Accurate differential backup actually worked, I do not know yet
(see other thread titled `More Bacula 7.4.4 differential Backup
strangeness'), that will take more investigation.


On 10/14/2016 01:50 PM, Andreas Koch wrote:
> Hello all,
> we have observed strange behavior in our recent backups. We have a number
> of filesystems, and explicitly list those to be backed up in the fileset
> One of these file systems is
> /home/stud
> which has subdirectories for each user. Backing these up has worked
> perfectly for the last decade by just including the file system in the
> FileSet
> FileSet { Name = "fs_gundabad" Include { Options { signature = SHA1; 
> verify=pins1; accurate=pins1; xattrsupport = yes; } ... File =
> /home/stud ... }
> However, a recent differential backup shows warnings for _all_ of user 
> subdirectories of the form:
> 13-Oct 03:25 gundabad-fd JobId 2161:      /home/stud/aqsprak01 is a
> different filesystem. Will not descend from /home/stud into it. 13-Oct
> 03:25 gundabad-fd JobId 2161:      /home/stud/aqsprak02 is a different 
> filesystem. Will not descend from /home/stud into it. ...
> Even stranger, the backup _does_ appear to contain files from these 
> directories (or more accurately, shows them in the catalog):
> * list files jobid=2161 ... 
> /home/stud/aqsprak01/Templates/test01/projSRC_Master/3cuS_1_l.dat ...
> Has anyone observed something like this elsewhere? As I wrote above, we
> use Bacula 7.4.4, on Scientific Linux 7.2 backing-up NFS v4.0 filesystems
> mounted via automounter from an EMC VNX 5200.
> Best, Andreas
Version: GnuPG v2


Check out the vibrant tech community on one of the world's most 
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
Bacula-users mailing list

Reply via email to