Try using the .spec files that are released with Bacula 9.0.6 rather than the RedHat spec files.  If you are using the community .spec files, let me know and I will make sure that they are the same ones our packager is using (sometimes packagers modify packages but the changes don't always get pushed back to the source).

Best regards,

Kern


On 04/05/2018 04:50 PM, Matthias Leopold wrote:
Hi,

I'm absolutely new to Bacula and basically only want to package the software for CentOS 7 so it can be used in my organization by others. I'm compiling RPMs from the spec files in bacula-9.0.6.tar.gz. I chose "%define postgresql 1" so i got a bacula-postgresql-9.0.6-1.x86_64.rpm package. When i want install it from our spacewalk server i get the following message:

Error: Package: bacula-postgresql-9.0.6-1.x86_64 (our_custom_channel_x86_64)
           Requires: libbaccats-9.0.6.so()(64bit)

When i look at the spec file i see that only the mysql package would get a "Provides: libbaccats-%{version}.so()(64bit)". How is installing packages supposed to work with postgresql versions of Bacula?

thx for any advice
matthias



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Bacula-users mailing list
Bacula-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/bacula-users



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Bacula-users mailing list
Bacula-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/bacula-users

Reply via email to