Hi folks,

due to user error part of a file system on one of our backup clients
was compressed by a find command gone haywire. Among them are
/usr/bin/bash & others (kernel, initrd, grub, root, authorized_keys
etc), leading to a situation where we cannot log into the system
remotely nor via the vmware console function anymore. 

I've tried to restore /usr/bin/bash by its uncompressed version as the
bacula-fd on the client is still running (today's incr. backup worked
fine, too), but once the restore starts I'm getting the following

31-Oct 12:23 deniol2378-sd JobId 23316: Forward spacing Volume "deXXXXX-0183" 
to addr=269
31-Oct 12:23 deniol2378-sd JobId 23316: Elapsed time=00:00:01, Transfer 
rate=484.9 K Bytes/second
31-Oct 12:22 bacula-fd JobId 23316: Error: create_file.c:227 Could not create 
/usr/bin/bash: ERR=Permission denied
31-Oct 12:23 deniol2378-dir JobId 23316: Bacula deYYYYYY-dir 13.0.0 (04Jul22):

the bacula-fd runs as root on the client so it should have no issue
creating the file in the local filesystem... any idea what could be
causing this? It's also weird that I'm seeing a "restore OK" message
at the end of the job output:

  Replace:                Always
  Start time:             31-Oct-2022 12:23:02
  End time:               31-Oct-2022 12:23:02
  Elapsed time:           1 sec
  Files Expected:         1
  Files Restored:         1
  Bytes Restored:         0 (0 B)
  Rate:                   0.0 KB/s
  FD Errors:              0
  FD termination status:  OK
  SD termination status:  OK
  Termination:            Restore OK

I'm clutching at straws here naturally, however before we rebuild the
VM in question from a full backup I'd like to try as many options as

What makes this case even worse is that LVM is being used for / &
other fileystems, so we cannot simply mount those drives on another VM
(3 physical volumes) to repair the damage, right?

Thanks for reading this far & for your help,


Bacula-users mailing list

Reply via email to