Hi, now it is running. Thanks. Now the lcd is dark. How to launch the gui?
- - -
diff --git a/arch/arm/boards/freescale-mx28-evk/lowlevel.c
b/arch/arm/boards/freescale-mx28-evk/lowlevel.c
index 4d45a03..10f7ef6 100644
--- a/arch/arm/boards/freescale-mx28-evk/lowlevel.c
+++ b/arch/arm/boards/freescale-mx28-evk/lowlevel.c
@@ -14,7 +14,7 @@
 
 ENTRY_FUNCTION(start_barebox_freescale_mx28evk, r0, r1, r2)
 {
-       barebox_arm_entry(IMX_MEMORY_BASE, SZ_128M, NULL);
+       barebox_arm_entry(IMX_MEMORY_BASE, SZ_64M, NULL);
 }
- - -

got MAC address from IIM: 00:04:f8:5d:d7:cf
FEC0
Warning: FEC0 MAC addresses don't match:
Address in SROM is         00:04:f8:5d:d7:cf
Address in environment is  02:00:92:b3:c4:a8

Hit any key to stop autoboot:  0
MX28 U-Boot > <INTERRUPT>
MX28 U-Boot > <INTERRUPT>
MX28 U-Boot > <INTERRUPT>
MX28 U-Boot > <INTERRUPT>
MX28 U-Boot > <INTERRUPT>
MX28 U-Boot > tftpboot barebox-freescale-mx28evk-2nd.img
Using FEC0 device
TFTP from server 192.168.12.61; our IP address is 192.168.12.62
Filename 'barebox-freescale-mx28evk-2nd.img'.
Load address: 0x41600000
Loading: T #################
done
Bytes transferred = 237783 (3a0d7 hex)
MX28 U-Boot > go 0x41600000
## Starting application at 0x41600000 ...
initcall-> globalvar_init+0x0/0x38
initcall-> platform_init+0x0/0xc
initcall-> mdio_bus_init+0x0/0xc
initcall-> spi_bus_init+0x0/0xc
initcall-> gpio_desc_alloc+0x0/0x20
initcall-> fs_bus_init+0x0/0xc
initcall-> mxs_gpio_add+0x0/0x18
initcall-> imx28_clocksource_init+0x0/0x54
initcall-> unwind_init+0x0/0x30
initcall-> imx28_ccm_init+0x0/0xc
initcall-> net_init+0x0/0x88
initcall-> init_fs+0x0/0x3c
initcall-> mxs_init+0x0/0xdc
detected i.MX28 revision 1.2
initcall-> imx28_devices_init+0x0/0x144
initcall-> imx28_init+0x0/0x2c
initcall-> stm_serial_driver_register+0x0/0xc
initcall-> auart_serial_driver_register+0x0/0xc
initcall-> mx28_evk_console_init+0x0/0x54
Switch to console [cs0]


barebox 2018.02.0-00077-g359966d-dirty #12 Fri Mar 2 18:37:29 CST 2018


Board: Freescale i.MX28 EVK
initcall-> globalvar_init+0x0/0x38
initcall-> platform_init+0x0/0xc 

-----邮件原件-----
发件人: 'Sascha Hauer' [mailto:s.ha...@pengutronix.de] 
发送时间: 2018年3月2日 18:15
收件人: duhuanpeng
抄送: barebox@lists.infradead.org
主题: Re: 答复: freescale-mx28-evk run from ram

On Fri, Mar 02, 2018 at 05:01:37PM +0800, duhuanpeng wrote:
> > I assume you use freescale-mx28-evk_defconfig, right?
> Yes.
> 
> Which image do you start? It seems you are trying to start barebox.bin.
> > barebox.bin and barebox-freescale-mx28evk-2nd.img
> It should be images/barebox-freescale-mx28evk-2nd.img instead.
> 
> The image should be linked to 0x0, that is right. The code is position 
> independent though and the full barebox relocates itself to the end of 
> the available SDRAM automatically. TEXT_BASE is not relevant here.
> The start symbol is still 0x00000000 even I change TEXT_BASE in
menuconfig.
> my board have 64MiB ram. Modified board. 
> Very cheap one, just 33?. :D
> EasyARM-i.MX283A

You are running on a board which actually is no mx28-evk, so it's no wonder
it doesn't work. Please mention that next time, because that changes the
question from "What is broken with the mx28-evk" to "What is different on
your board". This is a very important detail to answer questions.

Anyway, you say your board only has 64MiB of RAM, so you must at least
change:

ENTRY_FUNCTION(start_barebox_freescale_mx28evk, r0, r1, r2) {
        barebox_arm_entry(IMX_MEMORY_BASE, SZ_128M, NULL); }

to SZ_64M. Other differences might include the pinmux and the UART port
number which is used for console output.

Sascha

-- 
Pengutronix e.K.                           |                             |
Industrial Linux Solutions                 | http://www.pengutronix.de/  |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |




_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox

Reply via email to