I built the packages with mysql (mariadb) support and started following the
directions. I build the 16.2.7 version as that was the latest in portage,
but I've also tried 17.2.5 and am getting the same problem.

 

I run the database scripts (create, make, grant). They work, but they
complain about the database type and username etc not being specified. In
the /tmp logs, I see things like this: 

 

Unknown database driver: XXX_REPLACE_WITH_DATABASE_DRIVER_XXX

Error: executing /usr/sbin/bareos-dbcheck -c /etc/bareos -B

 

I have no trouble starting bareos-fd and bareos-sd, but bareos-dir
immediately exits. If I run it with the -f flag, I see this same error about
unknown database driver. I don't see any way to specify a database driver.

 

What am I doing wrong here?

 

Thanks.

 

-- 
You received this message because you are subscribed to the Google Groups 
"bareos-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to bareos-users+unsubscr...@googlegroups.com.
To post to this group, send email to bareos-users@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to