KuiLIU created BATIK-1221:
-----------------------------

             Summary: Inconsistent method name
                 Key: BATIK-1221
                 URL: https://issues.apache.org/jira/browse/BATIK-1221
             Project: Batik
          Issue Type: Improvement
            Reporter: KuiLIU


The following method is names as "convertOverflow", but the method does convert 
any 'Overflow' but just checks whether the element 'e' is overflow or not.
Thus, the method name should be "isOverflow".

{code:java}
 public static boolean convertOverflow(Element e) {
        Value v = getComputedStyle(e, SVGCSSEngine.OVERFLOW_INDEX);
        String s = v.getStringValue();
        return (s.charAt(0) == 'h') || (s.charAt(0) == 's');
    }
{code}




--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: batik-dev-unsubscr...@xmlgraphics.apache.org
For additional commands, e-mail: batik-dev-h...@xmlgraphics.apache.org

Reply via email to