I posted something yesterday but it seems to have vanished. I've run into 
this difficult before where none of the instructions or tutorials for 
getting internet connectivity via ethernet over USB work. Someone MUST have 
solved this. I'm running Debian Stretch/testing on my laptop. As far as the 
network manager goes, I don't think it's much different than Jessie 
(although I could be wrong). Here's specifically what I'm trying to do...

I have a laptop with a WiFi connection
I have a BeagleBone Black connected via USB.
I can ssh into the BBB no problem. What I can't do (which I'd like to be 
able to do) is to access the internet using my laptop's connection.

I've tried this:
1. SSH to the BBB:

ssh debian@

2. In the BBB console type the following:

sudo ifconfig usb0
sudo route add default gw

3. In the linux console of host system (Ubuntu) type:

sudo su
#wlan0 is my internet facing interface, eth1 is the BeagleBone USB 
ifconfig eth1
iptables --table nat --append POSTROUTING --out-interface wlan0 -j 
iptables --append FORWARD --in-interface eth1 -j ACCEPT
echo 1 > /proc/sys/net/ipv4/ip_forward

4. Set the DNS server address in the BBB console:

echo "nameserver" >> /etc/resolv.conf

It doesn't work.

I've tried this (creating a bridge):


... and that didn't work either.

Any help would be greatly appreciated.

For more options, visit http://beagleboard.org/discuss
You received this message because you are subscribed to the Google Groups 
"BeagleBoard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to beagleboard+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to