On Tue, Sep 20, 2016 at 12:38 PM, Robert Nelson <robertcnel...@gmail.com> wrote:
> On Tue, Sep 20, 2016 at 12:32 PM, Robert Nelson <robertcnel...@gmail.com> 
> wrote:
>> On Tue, Sep 20, 2016 at 12:17 PM, Robert Nelson <robertcnel...@gmail.com> 
>> wrote:
>>> On Tue, Sep 20, 2016 at 12:05 PM, Dave Lynch <dhlyn...@gmail.com> wrote:
>>>> That image is not working for me either.
>>>>
>>>> If I am following this, there is an issue where the eMMC is being
>>>> partitioned as if it is 4G instead of 2G correct ?
>>>>
>>>> If I just modify the sfdisk portion of the Flash script will that correct
>>>> this ?
>>>>
>>>
>>> Humm..
>>>
>>> i had just tested
>>> BBB-eMMC-flasher-debian-8.5-console-armhf-2016-09-09-2gb.img.xz this
>>> morning on a Rev C.. (it had flashed just fine)
>>>
>>> Let's try it on one of my old A5A's.. (that's close to your A6)..
>>
>> So on my A5A...
>>
>>
>> U-Boot SPL 2016.09-rc2-00001-g2e7c9a7 (Sep 09 2016 - 14:20:16)
>> Trying to boot from MMC2
>> Expected Linux image is not found. Trying to start U-boot
>>
>>
>> U-Boot 2016.09-rc2-00001-g2e7c9a7 (Sep 09 2016 - 14:20:16 -0500),
>> Build: jenkins-github_Bootloader-Builder-446
>>
>> DRAM:  512 MiB
>> Reset Source: Power-on reset has occurred.
>> MMC:   OMAP SD/MMC: 0, OMAP SD/MMC: 1
>> Using default environment
>>
>> Board: BeagleBone Black
>> Net:
>> Warning: ethernet@4a100000 using MAC address from ROM
>> eth0: ethernet@4a100000
>> Press SPACE to abort autoboot in 2 seconds
>> board_name=[A335BNLT] ...
>> board_rev=[0A5A] ...
>> Card did not respond to voltage select!
>> Card did not respond to voltage select!
>> Card did not respond to voltage select!
>> gpio: pin 56 (gpio 56) value is 0
>> gpio: pin 55 (gpio 55) value is 0
>> gpio: pin 54 (gpio 54) value is 0
>> gpio: pin 53 (gpio 53) value is 1
>> Card did not respond to voltage select!
>> Card did not respond to voltage select!
>> ** First descriptor is NOT a primary desc on 1:1 **
>> switch to partitions #0, OK
>> mmc1(part 0) is current device
>> ** No partition table - mmc 1 **
>> gpio: pin 56 (gpio 56) value is 0
>> gpio: pin 55 (gpio 55) value is 0
>> gpio: pin 54 (gpio 54) value is 0
>> gpio: pin 53 (gpio 53) value is 1
>> ** First descriptor is NOT a primary desc on 1:1 **
>> switch to partitions #0, OK
>> mmc1(part 0) is current device
>> ** First descriptor is NOT a primary desc on 1:1 **
>> gpio: pin 54 (gpio 54) value is 1
>> ** No partition table - mmc 1 **
>> Checking for: /uEnv.txt ...
>> ** No partition table - mmc 1 **
>> Checking for: /boot.scr ...
>> ** No partition table - mmc 1 **
>> Checking for: /boot/boot.scr ...
>> ** No partition table - mmc 1 **
>> Checking for: /boot/uEnv.txt ...
>> ** No partition table - mmc 1 **
>> ** No partition table - mmc 1 **
>> ** No partition table - mmc 1 **
>> ** No partition table - mmc 1 **
>> ** No partition table - mmc 1 **
>> ** No partition table - mmc 1 **
>> ** No partition table - mmc 1 **
>> starting USB...
>> USB0:   Port not available.
>> ethernet@4a100000 Waiting for PHY auto negotiation to complete
>>
>> Crap!
>
> => mmc list
> OMAP SD/MMC: 0
> OMAP SD/MMC: 1 (eMMC)
> => mmc dev 1
> ** First descriptor is NOT a primary desc on 1:1 **
> switch to partitions #0, OK
> mmc1(part 0) is current device
> => mmc part
> ## Unknown partition table type 0
> => ums 0 mmc 1
> UMS: LUN 0, dev 1, hwpart 0, sector 0x0, count 0x394000
> musb-hdrc: peripheral reset irq lost!
>
> x86 (usb)
>
> [13599.751428] sd 6:0:0:0: [sdb] Attached SCSI removable disk
> [14831.039791] sd 6:0:0:0: [sdb] 3751936 512-byte logical blocks:
> (1.92 GB/1.79 GiB)
> [14831.040085] sd 6:0:0:0: [sdb] Write Protect is off
> [14831.040088] sd 6:0:0:0: [sdb] Mode Sense: 0f 00 00 00
> [14831.040409] sd 6:0:0:0: [sdb] Write cache: enabled, read cache:
> enabled, doesn't support DPO or FUA
> [14831.052981] sd 6:0:0:0: [sdb] Attached SCSI removable disk
> voodoo@hades:/opt/images/elinux/2016-09-09/flasher$ sudo fdisk -l /dev/sdb
> [sudo] password for voodoo:
> Disk /dev/sdb: 1.8 GiB, 1920991232 bytes, 3751936 sectors
> Units: sectors of 1 * 512 = 512 bytes
> Sector size (logical/physical): 512 bytes / 512 bytes
> I/O size (minimum/optimal): 512 bytes / 512 bytes
> voodoo@hades:/opt/images/elinux/2016-09-09/flasher$
>
> okay, that's not good, even the block exported to my x86 linux desktop
> is not showing a partition..

moving the partition table back from 4MB -> 1MB... no change..

Regards,

-- 
Robert Nelson
https://rcn-ee.com/

-- 
For more options, visit http://beagleboard.org/discuss
--- 
You received this message because you are subscribed to the Google Groups 
"BeagleBoard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to beagleboard+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/beagleboard/CAOCHtYgrRYBw4Zqw8i763BfmBrzf1-hfoaoD%3Df3VToGubg1CuA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to