Hi,

I started Reading about dts files a few days ago and wrote my own to set 
P8.42, P8.43, P8.44 and P8.46 as gpio outputs. I compiled it and tried to 
echo it to /sys/devices/platform/bone_capemgr/slots, but I get no response 
(my terminal just stops).

Here's what I get on dmesg's last lines:
[  407.020467] bone_capemgr bone_capemgr: part_number 'bb-gpio', version 
'N/A'
[  407.020531] bone_capemgr bone_capemgr: slot #4: override
[  407.033061] bone_capemgr bone_capemgr: slot #4: auto loading handled by 
U-Boot

And here's my custom dts:

/dts-v1/;
/plugin/;
/ {
 compatible = "ti,beaglebone", "ti,beaglebone-black";
 /* identification */
 part-number = "bb-gpio";
 version = "00a0";
 /* state the resources this cape uses */
 exclusive-use =
 "P8.42",
 "P8.43",
 "P8.44",
 "P8.46",
 "gpio2_11",
 "gpio2_8",
 "gpio2_9",
 "gpio2_7";
 fragment@0 {
  target = <&am33xx_pinmux>;
  __overlay__ {
   bb_gpio_pins: pinmux_bb_gpio_pins {
    pinctrl-single,pins = <
    0x0b4 0x0f /* P8_42 GPIO2_11 */
    0x0a8 0x0f /* P8_43 GPIO2_8 */
    0x0ac 0x0f /* P8_44 GPIO2_9 */
    0x0a4 0x0f /* P8_46 GPIO2_7 */
    >;
   };
  };
 };
 fragment@1 {
  target = <&ocp>;
  __overlay__ {
   bbgpio : gpio {
    pinctrl-names = "default";
    pinctrl-0 = <&bb_gpio_pins>;
    status = "okay";
    /*oe {
     gpio-name = "oe";
     gpio = <&gpio3 11 0x00>;
     output;
    };
    clk {
     gpio-name = "clk";
     gpio = <&gpio3 8 0x00>;
     output;
    };
    le {
     gpio-name = "le";
     gpio = <&gpio3 9 0x00>;
     output;
    };
    sdi {
     gpio-name = "sdi";
     gpio = <&gpio3 7 0x00>;
     output;
    };*/
   };
  };
 };
};


I tried upgrading kernel (right now, *uname -a* returns: Linux arm 
4.9.41-ti-r53 #1 SMP PREEMPT Thu Aug 10 02:34:57 UTC 2017 armv7l 
GNU/Linux), disabling audio/vĂ­deo/wireless/adc overlays, enabling/disabling 
cape_universal, loading internet dtbos (from kilobaser 
<http://www.kilobaser.com/blog/2014-07-28-beaglebone-black-devicetreeoverlay-generator>and
 
bbbadventures <http://bbbadventures.blogspot.com.br/2013/06/pinmuxing.html>) 
and default ones (like cape-universaln) and changing boards (I have 2 BBBs) 
and installing bb-cape-overlays through apt-get

I think I'm missing something really stupid, because I found nothing 
regarding this kind of error so far.
If I try to load the dtbos on boot through uEnv.txt, my board stops with 
the 4 user leds lit, which I understand as a signal that my BBB is not 
loading the OS. Of course, I can't ssh it.

What am I missing?

Best regards,
Marco

-- 
For more options, visit http://beagleboard.org/discuss
--- 
You received this message because you are subscribed to the Google Groups 
"BeagleBoard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to beagleboard+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/beagleboard/d7b3a25d-e723-4fa2-ab46-2eb014a10bbe%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to