#8341: Incorrect LLVM dependency in Mesa
-------------------------+--------------------------
 Reporter:  Krejzi       |       Owner:  blfs-book@…
     Type:  enhancement  |      Status:  new
 Priority:  normal       |   Milestone:  7.11
Component:  BOOK         |     Version:  SVN
 Severity:  normal       |  Resolution:
 Keywords:               |
-------------------------+--------------------------
Description changed by Krejzi:

Old description:

> Note on the Mesa page states that LLVM and elfutils are required for
> several drivers.
>
> That's not entirely true.
>
> LLVM only is required for r300 (not elfutils).
>
> Neither LLVM or elfutils are needed for r600 unless one uses
> --enable-r600-llvm-compiler or enables OpenCL, neither which is default
> in BLFS; Former switch shouldn't be done anyways, SB is superior to llvm
> compiler.
>
> {{{
>  --enable-r600-llvm-compiler: Use this switch to enable an experimental
> R600 LLVM backend for graphics shaders which claims to speed up the
> driver.
> }}}
>
> This statement should be reworked/removed, as it's no longer true (it may
> have been at one period in the past).
>
> Both elfutils and LLVM are required only for radeonsi.
>
> And still, only LLVM, without AMDGPU target, is needed for swr/llvmpipe.
> If llvm is not present, llvmpipe won't be built, but softpipe will be
> (both are different swrast implementations).
>
> https://cgit.freedesktop.org/mesa/mesa/tree/configure.ac#n2409
> https://cgit.freedesktop.org/mesa/mesa/tree/configure.ac#n2318

New description:

 Note on the Mesa page states that LLVM and elfutils are required for
 several drivers.

 That's not entirely true.

 LLVM only is required for r300 (not elfutils).

 Neither LLVM or elfutils are needed for r600 unless one uses --enable-r600
 -llvm-compiler or enables OpenCL, neither which is default in BLFS; Former
 switch shouldn't be done anyways, SB is superior to llvm compiler.

 {{{
  --enable-r600-llvm-compiler: Use this switch to enable an experimental
 R600 LLVM backend for graphics shaders which claims to speed up the
 driver.
 }}}

 This statement should be reworked/removed, as it's no longer true (it may
 have been at one period in the past).

 Both elfutils and LLVM are required only for radeonsi.

 And still, only LLVM, without AMDGPU target, is needed for swr/llvmpipe.
 If llvm is not present, llvmpipe won't be built, but softpipe will be
 (both are different swrast implementations).

 https://cgit.freedesktop.org/mesa/mesa/tree/configure.ac#n2409

 https://cgit.freedesktop.org/mesa/mesa/tree/configure.ac#n2318

--

--
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/8341#comment:1>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Reply via email to