Author: pierre
Date: Thu Oct 13 09:25:58 2016
New Revision: 17880

Log:
Yet another run of option vs parameter fixes

Modified:
   trunk/BOOK/gnome/applications/file-roller.xml
   trunk/BOOK/multimedia/libdriv/alsa-utils.xml
   trunk/BOOK/multimedia/libdriv/gavl.xml
   trunk/BOOK/multimedia/libdriv/gst10-plugins-bad.xml
   trunk/BOOK/multimedia/libdriv/liba52.xml
   trunk/BOOK/x/lib/qt5.xml
   trunk/BOOK/xsoft/other/ekiga.xml
   trunk/BOOK/xsoft/other/pidgin.xml
   trunk/BOOK/xsoft/other/xarchiver.xml
   trunk/BOOK/xsoft/other/xchat.xml

Modified: trunk/BOOK/gnome/applications/file-roller.xml
==============================================================================
--- trunk/BOOK/gnome/applications/file-roller.xml       Thu Oct 13 07:36:45 
2016        (r17879)
+++ trunk/BOOK/gnome/applications/file-roller.xml       Thu Oct 13 09:25:58 
2016        (r17880)
@@ -141,7 +141,7 @@
     <title>Command Explanations</title>
 
     <para>
-      <option>--disable-packagekit</option>: This switch disables the use
+      <parameter>--disable-packagekit</parameter>: This switch disables the use
       of PackageKit which isn't suitable for BLFS.
     </para>
 

Modified: trunk/BOOK/multimedia/libdriv/alsa-utils.xml
==============================================================================
--- trunk/BOOK/multimedia/libdriv/alsa-utils.xml        Thu Oct 13 07:36:45 
2016        (r17879)
+++ trunk/BOOK/multimedia/libdriv/alsa-utils.xml        Thu Oct 13 09:25:58 
2016        (r17880)
@@ -121,25 +121,25 @@
     <title>Command Explanations</title>
 
     <para>
-      <option>--disable-alsaconf</option>: This switch disables building the
-      <command>alsaconf</command> configuration tool which is incompatible with
-      <application>Udev</application>.
+      <parameter>--disable-alsaconf</parameter>: This switch disables building
+      the <command>alsaconf</command> configuration tool which is incompatible
+      with <application>Udev</application>.
     </para>
 
     <para>
-      <option>--disable-xmlto</option>: Omit this switch if you have installed
-      <xref linkend="xmlto"/> and want to regenerate the man pages.
+      <parameter>--disable-xmlto</parameter>: Omit this switch if you have
+      installed <xref linkend="xmlto"/> and wish to regenerate the man pages.
     </para>
 
     <para>
-      <option>--disable-bat</option>: Omit this switch if you have installed
-      <ulink url="http://www.fftw.org/";>FFTW</ulink> and wish to install
-      the Basic Audio Tester (BAT).
+      <parameter>--disable-bat</parameter>: Omit this switch if you have
+      installed <ulink url="http://www.fftw.org/";>FFTW</ulink> and wish to
+      install the Basic Audio Tester (BAT).
     </para>
 
     <para>
-      <option>--with-curses=ncursesw</option>: This switch forces the use of
-      wide-character ncurses libraries.
+      <parameter>--with-curses=ncursesw</parameter>: This switch forces the
+      use of wide-character ncurses libraries.
     </para>
 
   </sect2>

Modified: trunk/BOOK/multimedia/libdriv/gavl.xml
==============================================================================
--- trunk/BOOK/multimedia/libdriv/gavl.xml      Thu Oct 13 07:36:45 2016        
(r17879)
+++ trunk/BOOK/multimedia/libdriv/gavl.xml      Thu Oct 13 09:25:58 2016        
(r17880)
@@ -99,8 +99,8 @@
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><parameter>--disable-doxygen</parameter>: This switch disables use of
-    Doxygen. Omit if you have Doxygen install and wish to build the API
+    <para><parameter>--without-doxygen</parameter>: This switch disables use of
+    Doxygen. Omit if Doxygen is installed and you wish to build the API
     documentation.</para>
 
   </sect2>

Modified: trunk/BOOK/multimedia/libdriv/gst10-plugins-bad.xml
==============================================================================
--- trunk/BOOK/multimedia/libdriv/gst10-plugins-bad.xml Thu Oct 13 07:36:45 
2016        (r17879)
+++ trunk/BOOK/multimedia/libdriv/gst10-plugins-bad.xml Thu Oct 13 09:25:58 
2016        (r17880)
@@ -203,7 +203,7 @@
     <title>Command Explanations</title>
 
     <para>
-      <option>--disable-wayland</option>: This options is required
+      <parameter>--disable-wayland</parameter>: This switch is required
       without a full wayland based desktop environment.
     </para>
 

Modified: trunk/BOOK/multimedia/libdriv/liba52.xml
==============================================================================
--- trunk/BOOK/multimedia/libdriv/liba52.xml    Thu Oct 13 07:36:45 2016        
(r17879)
+++ trunk/BOOK/multimedia/libdriv/liba52.xml    Thu Oct 13 09:25:58 2016        
(r17880)
@@ -97,8 +97,8 @@
     (which is the default) but then on x86_64 adds -fPIC. This is needed to
     compile <application>liba52</application> on x86_64.</para>
 
-    <para><option>--disable-static</option>: This option stops it installing
-    the static version of the library.</para>
+    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude";
+      href="../../xincludes/static-libraries.xml"/>
 
     <para><command>cp liba52/a52_internal.h ...</command>: Copying this header
     file into /usr/include/a52dec allows some other programs (such as

Modified: trunk/BOOK/x/lib/qt5.xml
==============================================================================
--- trunk/BOOK/x/lib/qt5.xml    Thu Oct 13 07:36:45 2016        (r17879)
+++ trunk/BOOK/x/lib/qt5.xml    Thu Oct 13 09:25:58 2016        (r17880)
@@ -442,11 +442,6 @@
     </para>
 
     <para>
-      <parameter>-optimized-qmake</parameter>: This switch enables
-      building of the optimized <command>qmake</command> program.
-    </para>
-
-    <para>
       <parameter>-system-harfbuzz</parameter>: This switch enables use
       of the system version of <application>Harfbuzz</application>
       which fixes some font rendering issues in

Modified: trunk/BOOK/xsoft/other/ekiga.xml
==============================================================================
--- trunk/BOOK/xsoft/other/ekiga.xml    Thu Oct 13 07:36:45 2016        (r17879)
+++ trunk/BOOK/xsoft/other/ekiga.xml    Thu Oct 13 09:25:58 2016        (r17880)
@@ -119,8 +119,7 @@
             --sysconfdir=/etc \
             --disable-eds     \
             --disable-gdu     \
-            --disable-ldap    \
-            --disable-scrollkeeper &amp;&amp;
+            --disable-ldap    &amp;&amp;
 make</userinput></screen>
 
     <para>

Modified: trunk/BOOK/xsoft/other/pidgin.xml
==============================================================================
--- trunk/BOOK/xsoft/other/pidgin.xml   Thu Oct 13 07:36:45 2016        (r17879)
+++ trunk/BOOK/xsoft/other/pidgin.xml   Thu Oct 13 09:25:58 2016        (r17880)
@@ -191,47 +191,47 @@
     <title>Command Explanations</title>
 
     <para>
-      <option>--with-gstreamer=1.0</option>: Remove this switch
+      <parameter>--with-gstreamer=1.0</parameter>: Remove this switch
       and add <option>--disable-gstreamer</option>
       if you've not installed <xref linkend="gstreamer10"/>.
     </para>
 
     <para>
-      <option>--disable-avahi</option>: Remove this switch if you've
+      <parameter>--disable-avahi</parameter>: Remove this switch if you've
       installed <xref linkend="avahi"/>.
     </para>
 
     <para>
-      <option>--disable-gtkspell</option>: Spellchecking. Remove this switch if
-      you've installed
+      <parameter>--disable-gtkspell</parameter>: Spellchecking. Remove this
+      switch if you've installed
       <ulink url="http://gtkspell.sourceforge.net/";>Gtkspell</ulink>.
     </para>
 
     <para>
-      <option>--disable-meanwhile</option>: Remove this switch if you've
+      <parameter>--disable-meanwhile</parameter>: Remove this switch if you've
       installed <ulink 
url="http://meanwhile.sourceforge.net/";>Meanwhile</ulink>.
     </para>
 
     <para>
-      <option>--disable-idn</option>: Remove this switch if you've installed
-      <xref linkend="libidn"/>.
+      <parameter>--disable-idn</parameter>: Remove this switch if you've
+      installed <xref linkend="libidn"/>.
     </para>
 
     <para>
-      <option>--disable-nm</option>: Remove this switch if you've installed
-      <xref linkend="NetworkManager"/>.
+      <parameter>--disable-nm</parameter>: Remove this switch if you've
+      installed <xref linkend="NetworkManager"/>.
     </para>
 
     <para>
-      <option>--disable-vv</option>: Video and voice. Remove this switch if
-      you've installed
+      <parameter>--disable-vv</parameter>: Video and voice. Remove this
+      switch if you've installed
       <ulink url="http://www.freedesktop.org/wiki/Software/Farstream";>
       Farstream (Version 0.1)</ulink>.
     </para>
 
     <para>
-      <option>--disable-tcl</option>: Remove this switch if you've installed
-      <xref linkend="tcl"/>.
+      <parameter>--disable-tcl</parameter>: Remove this switch if you've
+      installed <xref linkend="tcl"/>.
     </para>
 
     <para>

Modified: trunk/BOOK/xsoft/other/xarchiver.xml
==============================================================================
--- trunk/BOOK/xsoft/other/xarchiver.xml        Thu Oct 13 07:36:45 2016        
(r17879)
+++ trunk/BOOK/xsoft/other/xarchiver.xml        Thu Oct 13 09:25:58 2016        
(r17880)
@@ -159,7 +159,7 @@
     </para>
 
     <para>
-      <parameter>---disable-gtk3</parameter>: This switch chooses to build
+      <parameter>---disable-gtk3</parameter>: This switch allows building
       against GTK+2. Default is <parameter>--enable-gtk3</parameter>. Remove it
       or replace it, if you wish to build against GTK+3.
     </para>

Modified: trunk/BOOK/xsoft/other/xchat.xml
==============================================================================
--- trunk/BOOK/xsoft/other/xchat.xml    Thu Oct 13 07:36:45 2016        (r17879)
+++ trunk/BOOK/xsoft/other/xchat.xml    Thu Oct 13 09:25:58 2016        (r17880)
@@ -119,13 +119,10 @@
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude";
-    href="../../xincludes/gnome-sysconfdir.xml"/>
-
     <para><parameter>--enable-shm</parameter>: This parameter is used to enable
     XShm for fast tinting.</para>
 
-    <para><parameter>--enable-ipv6</parameter>: Enable IPv6 support in 
xchat.</para>
+    <para><option>--enable-ipv6</option>: Enable IPv6 support in xchat.</para>
 
   </sect2>
 
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Reply via email to