Author: bdubbs
Date: Thu Feb 22 07:11:22 2018
New Revision: 19844

Log:
Update to mercurial-4.5.
Change default for docutils to python2.
Add a note to dependencies for gpgme.

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/general/prog/docutils.xml
   trunk/BOOK/general/prog/mercurial.xml
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/packages.ent
   trunk/BOOK/postlfs/security/gpgme.xml

Modified: trunk/BOOK/general.ent
==============================================================================
--- trunk/BOOK/general.ent      Wed Feb 21 21:51:10 2018        (r19843)
+++ trunk/BOOK/general.ent      Thu Feb 22 07:11:22 2018        (r19844)
@@ -1,12 +1,12 @@
 <!-- $LastChangedBy$ $Date$ -->
 
-<!ENTITY day          "21">                   <!-- Always 2 digits -->
+<!ENTITY day          "22">                   <!-- Always 2 digits -->
 <!ENTITY month        "02">                   <!-- Always 2 digits -->
 <!ENTITY year         "2018">
 <!ENTITY copyrightdate "2001-&year;">
 <!ENTITY copyholder   "The BLFS Development Team">
 <!ENTITY version      "&year;-&month;-&day;">
-<!ENTITY releasedate  "February 21st, &year;">
+<!ENTITY releasedate  "February 22nd, &year;">
 <!ENTITY pubdate      "&year;-&month;-&day;"> <!-- metadata req. by TLDP -->
 <!ENTITY blfs-version "svn">                  <!-- svn|[release #] -->
 <!ENTITY lfs-version  "development">          <!-- x.y|development -->

Modified: trunk/BOOK/general/prog/docutils.xml
==============================================================================
--- trunk/BOOK/general/prog/docutils.xml        Wed Feb 21 21:51:10 2018        
(r19843)
+++ trunk/BOOK/general/prog/docutils.xml        Thu Feb 22 07:11:22 2018        
(r19844)
@@ -66,6 +66,17 @@
         </listitem>
       </itemizedlist>
 
+      <bridgehead renderas="sect4">Docutils Dependencies</bridgehead>
+
+      <bridgehead renderas="sect5">Recommended</bridgehead>
+      <para role="recommended">
+        <xref linkend="python2"/>
+      </para>
+
+      <note><para>This package can be installed with 
+      <application>Python 3</application>, but some packages require
+      <application>Python 2</application>.</para></note>
+
       <para condition="html" role="usernotes">
         User Notes: <ulink url="&blfs-wiki;/docutils"/>
       </para>
@@ -77,19 +88,19 @@
 <!-- Editors note: Use - -root= instead of DESTDIR= when updating. -->
 
       <para>
-        To build the <application>Python 3</application> applications,
+        To build the <application>Python 2</application> applications,
         run the following command:
       </para>
 
-<screen><userinput>python3 setup.py build</userinput></screen>
+<screen><userinput>python setup.py build</userinput></screen>
 
       <para>
-        To install the <application>Python 3</application> applications
+        To install the <application>Python</application> applications
         run the following as the
         <systemitem class="username">root</systemitem> user:
       </para>
 
-<screen role="root"><userinput>python3 setup.py install --optimize=1 &amp;&amp;
+<screen role="root"><userinput>python setup.py install --optimize=1 &amp;&amp;
 
 for f in /usr/bin/rst*.py; do
   ln -svf $(basename $f) /usr/bin/$(basename $f .py)

Modified: trunk/BOOK/general/prog/mercurial.xml
==============================================================================
--- trunk/BOOK/general/prog/mercurial.xml       Wed Feb 21 21:51:10 2018        
(r19843)
+++ trunk/BOOK/general/prog/mercurial.xml       Thu Feb 22 07:11:22 2018        
(r19844)
@@ -6,10 +6,10 @@
 
   <!ENTITY mercurial-download-http 
"https://www.mercurial-scm.org/release/mercurial-&mercurial-version;.tar.gz";>
   <!ENTITY mercurial-download-ftp  " ">
-  <!ENTITY mercurial-md5sum        "95769125cf7e9dbc341a983253acefcd">
-  <!ENTITY mercurial-size          "5.4 MB">
-  <!ENTITY mercurial-buildsize     "51 MB (add 419 MB for tests)">
-  <!ENTITY mercurial-time          "0.2 SBU (add 6.3 SBU for tests using -j4)">
+  <!ENTITY mercurial-md5sum        "5ca07ebb0c7f7eeb7b5a8ca9822cb8f1">
+  <!ENTITY mercurial-size          "5.6 MB">
+  <!ENTITY mercurial-buildsize     "52 MB (add 523 MB for tests)">
+  <!ENTITY mercurial-time          "0.2 SBU (add 6.2 SBU for tests using -j4)">
 ]>
 
 <sect1 id="mercurial" xreflabel="Mercurial-&mercurial-version;">

Modified: trunk/BOOK/introduction/welcome/changelog.xml
==============================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml       Wed Feb 21 21:51:10 
2018        (r19843)
+++ trunk/BOOK/introduction/welcome/changelog.xml       Thu Feb 22 07:11:22 
2018        (r19844)
@@ -42,6 +42,16 @@
     </listitem>
 -->
     <listitem>
+      <para>February 22nd, 2018</para>
+      <itemizedlist>
+        <listitem>
+          <para>[bdubbs] - Update to mercurial-4.5. Fixes
+          <ulink url="&blfs-ticket-root;10394">#10394</ulink>.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
+    <listitem>
       <para>February 21st, 2018</para>
       <itemizedlist>
         <listitem>

Modified: trunk/BOOK/packages.ent
==============================================================================
--- trunk/BOOK/packages.ent     Wed Feb 21 21:51:10 2018        (r19843)
+++ trunk/BOOK/packages.ent     Thu Feb 22 07:11:22 2018        (r19844)
@@ -322,7 +322,7 @@
 <!ENTITY llvm-version                 "5.0.1">
 <!ENTITY llvm-old-version             "3.9.1">
 <!ENTITY lua-version                  "5.3.4">
-<!ENTITY mercurial-version            "4.4.2">
+<!ENTITY mercurial-version            "4.5">
 <!ENTITY nasm-version                 "2.13.03">
 <!ENTITY ninja-version                "1.8.2">
 <!ENTITY npapi-sdk-version            "0.27.2">

Modified: trunk/BOOK/postlfs/security/gpgme.xml
==============================================================================
--- trunk/BOOK/postlfs/security/gpgme.xml       Wed Feb 21 21:51:10 2018        
(r19843)
+++ trunk/BOOK/postlfs/security/gpgme.xml       Thu Feb 22 07:11:22 2018        
(r19844)
@@ -87,7 +87,8 @@
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional">
       <xref linkend="doxygen"/> (for API documentation),
-      <xref linkend="gnupg2"/> (used during the testsuite), and 
+      <xref linkend="gnupg2"/> (required if Qt or SWIG are installed; 
+        used during the testsuite),
       <xref linkend="clisp"/>, 
       <xref linkend="python2"/>, 
       <xref linkend="qt5"/>, and/or
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Reply via email to