#9168: rustc and cargo - do not update automatically
-------------------------+------------------------
 Reporter:  ken@…        |       Owner:  blfs-book
     Type:  enhancement  |      Status:  new
 Priority:  normal       |   Milestone:  y-hold
Component:  BOOK         |     Version:  SVN
 Severity:  normal       |  Resolution:
 Keywords:               |
-------------------------+------------------------

Comment (by ken@…):

 Just a reminder for myself (or anybody else who follows this) - although
 current versions build when using PYTHON=/usr/bin/python3, the shipped
 configure wrapper (which we sidestep since it only creates configure.toml)
 really prefers python2, and some of the python scripts (possibly used for
 build, as well as for some of the tests) force python2.7 using
 /usr/bin/env.

 Building with python3, 1.24.0 and 1.25.0 had appeared to work ok (I had
 had odd issues with 1.23.0), but in the last few hours I've seen more
 weirdness (my script exits after an apparently successful build). Using
 python2 I'm back in business.

--
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/9168#comment:10>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Reply via email to