On Friday 10 August 2012 20:41:47 Fernando de Oliveira wrote:
> The important differences with previous version are:
>             --without-krb5                                        \
>             --without-gssapi                                     &&
> I do not have them installed. (previous versions did not need these
> switches) and failed to build with system poppler:
>             #--with-system-poppler

Thanks for your input, Fernando. I have commited LO 3.6.0. Like you, I 
couldn't get LO to build with system Poppler. I tried both version 0.20.2 and 
0.20.3. It's a unit test (sdext_pdfimport.test) that fails, but the error 
message isn't particularly helpful:

Test name: N12_GLOBAL__N_18PDFITestE::testXPDFParser
assertion failed
- Expression: rtl::math::approxEqual(m_aHyperlinkBounds.X1,34.7 ) && 
:approxEqual(m_aHyperlinkBounds.Y1,386.0) && 
kBounds.X2,166.7) && rtl::math::approxEqual(m_aHyperlinkBounds.Y2,406.2)
- Correct hyperlink bounding box

I couldn't find any useful info on this on the web, so I decided to use the 
internal copy of Poppler for now.

Concerning krb5 and gssapi, I don't have them either, but the "without" 
switches weren't necessary.

I also included a patch to fix building with Boost 1.50.

>About version: it is my fault that we are using four digit version. I
>have seen a distro that does like that, but can't remember which one.
>The LO site has: "This release is bit-for-bit identical to the 3.6.0
>Release Candidate 4, so you don't need to download or reinstall if you
>have that version already." Therefore, even if it is not strictly wrong,
>I believe, we should change (as my mind has already) to using 3.6.0
>version, instead of, which seems to refer to a specific release
>candidate, not version.

I agree with you on this, so I removed the last ".4".

I don't have CUPS, so I built with --disable-cups. Now, if someone with CUPS 
1.6+ could test building LO...

FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Reply via email to